PDA

View Full Version : AggLibTools LibrariesLoader Problem (bytesLoaded and bytesTotal = "undefined")


FFighter
05-09-2006, 02:55 AM
Strange!

I have another function that also uses MovieClip loader after LibrariesLoader loads some swfs, and the onLoadProgress callback function returns the bytesTotal and bytesLoaded correclty, but the aggLibTools LibrariesLoader seems to have a bug. Iīm testing it locally with xat.com WebSpeed Simulator...

It loads all the swf files, but the feedback on bytesTotal and bytesLoaded isnīt given back (=undefined) so I canīt feed the preloader :(

Does anyone know what could be happening?

Thanks in advance,

FFighter
05-09-2006, 07:30 PM
So, no ideas on what could be happening? I tried to contact agglibtoolīs author but couldnīt find any contact form on his site: www.aggelos.org.

I really need some help here, I already tried to debug the code but everything seems allright... otherwise I would have to use other solution and the deadline is coming...

Thanks,

Marcelo.

FFighter
05-10-2006, 01:09 PM
So, hasnīt nobody ever used AggLibTools LibrariesLoader class and Sexie/SexieR (www.osflash.org/sexie)? Could anyone point me to its author then (as I couldnīt find any means to contact him)? I really need a solution quickly for this issue :(

Thanks,

- Marcelo.

FFighter
05-12-2006, 02:54 PM
Well, I ended up by giving up on AggLibTools and using PixLib (http://www.osflash.org/pixlib) instead, and it works like a charm, my only complaining is the additional kbs (8KB) it adds to my swf, but I can live with it ;)