PDA

View Full Version : Flex Builder F3 doesn't work


pet-theory
05-14-2006, 09:22 PM
I've installed Flex Builder Beta 3 today. It works fine, exept, the "go to source" (F3) and "open type" functions don't work. If, for instance, I hover over "MovieClip", this is the error message:

The source file cound not be found at C://....globalPlayer.swc.

Anyone else have this problem?

I have autocomplete and compile functionality.


Thanks

matt

pet-theory
05-14-2006, 09:23 PM
I should say that I'm in an AS3 project--though I tried to start a Flex project, and F3 doesn't work in there either.

Also, I'm running the standalone Builder in Virtual Pc.

I'm puzzled why Builder would look at a .swc file (isn't that a bunch of compiled components?) to find a source file, perhaps this is the bug? Or perhaps the .swc kicks the search out to the right source file?

A perusal of the FlexSDK and a search of my harddrive reveal no source file: MovieClip or flash.display.MovieClip...have I conceptualized this all wrong?

hangalot
05-15-2006, 08:35 AM
the moveiclip object is not an as class, and the only source that comes with the builder is the flex sourcecode.
movieclip is a native c++ object embeded in the player (otherwise it would be waaaay to slow)

pet-theory
05-15-2006, 02:43 PM
because let's say I'm in FlashDevelop, and I use the equivalent "go to source" command on a native object, the file that comes up looks more like an interface definition than a true class (which is useful just the same, it's a quick way to scan for methods).

So I checked, and F3 does work for variables and custom classes...but I guess there are no dummy "source" files yet for native classes in Flex Builder 2? I can live with that...I can just go to Help, though that's slow.

So does that mean everyone has this "bug"? I just want to be sure; when you hit F3 over "MovieClip", the same error message comes up?