PDA

View Full Version : Major JSFL Bug


ssacks
08-02-2006, 10:10 PM
If I make a JSFL file with this in it and run it using Run Command..., it works:

fl.getDocumentDOM().addNewText({left:10, top:10, right: 100, bottom:30}); fl.getDocumentDOM().setTextString("Hello World");


If I make a WindowSWF panel with the same thing in it, wrapped in MMExecute, it doesn't:

MMExecute("fl.getDocumentDOM().addNewText({left:10, top:10, right: 100, bottom:30})"); MMExecute("fl.getDocumentDOM().setTextString(\"Hello World\")");

It will addNewRectangle, it will addNewOval, etc. It WILL NOT addNewText no matter what I do, no matter how many ways I tried it.

This looks totally broken to me. Can anyone verify it?

senocular
08-02-2006, 10:22 PM
I just tried it and had no problems.

jjbilly
08-02-2006, 11:04 PM
just in case - did you close and restart flash after publishing the latest version of your WindowSWF?

luftbuefel
08-15-2006, 09:08 PM
Did you try changing the double quotation marks in the javascript code to single. This has worked for me before. Keep the double quotes in the actionscript bit though.