PDA

View Full Version : I know this is an amateur question


JuanSBach
09-07-2006, 08:38 PM
Hello Sorry for bothering but Im here alone against a project "second pro in flash" but first one thats going to be in a web site, so...the question is what should I do in the ActionScript code or into dream weaber to show my external files into de flash when I upload them to de site... cause in My pc all works fine: this is the code Im using and all files are together in a folder called Flash:

stop();
backgrounds = new Array("background0.swf", "background1.swf", "background2.swf");
function randomBackground() {
var randomNumber = random(backgrounds.length);
loadMovie(backgrounds[randomNumber], "background_mc");
}
randomBackground();


as you can see Im just copying an tutorial AScript and well it do not mention anything about something special when you upload your files to the web... Sorry if this an stupid think but I do not know how to solve it

tg
09-08-2006, 02:39 PM
if it works fine on your computer, but not on the server then:
1. check to make sure all files and file structures are the same
2. make sure that all file names are the same (including the letter case)

JuanSBach
09-08-2006, 03:15 PM
As I said I have in my folder site 2 more folders named Images and flash... all flash files are in the flash folder and as I said they work fine when I test the flash but even in the moment I test them in dreamweaver it dont recognize the script and then dont show the external files, OK I know that Is about the URL but Im not a programer at all Im just a Graphic designer against a whole project and this is the only problem I have till the moment so what should I ad tu the script to show the images cause I do not know so much about that script ....please really need that help cause Im gonna develop a slide show with many jpg so if cant know why is happening this the whole pro is going to be out of my hands

stompwampa
09-08-2006, 05:20 PM
I may be misreading your problem, but it doesn't sound like a coding problem, it sounds like a filing issue. If the site works fine when you test it on your computer, then that means all the local files are stored correctly. Try copying the folder and pasting it into your dreamweaver site root folder. Then from Dreamweaver, perform a "Put All" action which will then copy your local folder to be exactly the same as your server folder. There is also an option to update links, incase you moved something from where it was originally, Dreamweaver will automatically change anything linked to that file to the new location.

JuanSBach
09-08-2006, 05:54 PM
Again all is totally fine I mean.. I test my swf and it works....it loads de image in the position I just wanted.. but the same swf when I post it in dreamweaver when you push the test "f12" it do not show the external file, the pic...thats why I speculate is something about the code....I should put some setnence in the script like

backgrounds = new Array("http://www.sitename.com/, background0.swf");


well Ill try to find some similar issue Im pretty sure Im not the first one with this issue and by the way REALLY SORRY with my english, my native language is Spanish and Im doing a big effort cause my knoleged with english are from 1995 "basic school"... maybe thats why nobody understand the pro.. Im slaining it in the right way??'

stompwampa
09-08-2006, 08:32 PM
so you moved all your files into your Dreamweaver site folder? The thing is, if it works when you test the swf file externally, it should work when you test it online, since Flash packages everything into the swf file when you publish the movie.
Again, I may be misunderstanding your problem. . .

Your English if fine, by the way ;-)