PDA

View Full Version : fscommand in MX to launch Win Media Player Movie


sensoria
07-11-2002, 10:53 PM
Ok, I've gone through all the fscommand related posts and tutorials on this site hoping for an answer to my problems, but after trying all the suggestions, nothing seems to work.

The problem:

Saving my Flash MX project as a projector file to run off a CD in Windows. Within the projector are links to two Windows Media Player movies. I'm trying to use fscommand to launch the movies in Windows Media Player. The two movies, named 56K.wmv and 300K.wmv are both within a subfolder named "fscommand" at the root level of the CD-ROM.

While I've tried most of the code people have posted regarding fscommand, the last thing I tried is listed below:

on (release) {
fscommand ("exec", "56k.wmv");
}

I've also tried (from Jesse's tutorial - I also tried the other code from his other tutorials):

on (release) {
filename = "56k.wmv";
fscommand ("exec", "start\t" + filename);
fscommand ("exec", "cmd\t/c\t" + filename);
}

None of the above works.

Is it not possible to launch an external file from a CD using an MX Projector? Or is my brain just fried and I'm not doing it correctly?

And of course I have to get this CD-ROM to a client by the end of the week. God, I hate clients... :-)

Any help would be appreciated.

Regards,
Ron

Jesse
07-12-2002, 01:31 AM
Please remember to search before posting. I answerred this question twice already this week :) Flash MC supports the EXEC fscommand but only for files found in a specific subdirectory of the current SWF. See http://www.macromedia.com/support/flash/ts/documents/fscommand_projectors.htm

oldnewbie
07-12-2002, 03:17 AM
Jesse... No offense, but if you want Sensoria to search, you may want to read before answering...


...The two movies, named 56K.wmv and 300K.wmv are both within a subfolder named "fscommand" at the root level of the CD-ROM...

Regards,

;)

Jesse
07-12-2002, 03:21 AM
Indeed I jumped the gun. My apologies sensoria. Unfortuantely I believe in this case, what is required is the start method shown in the Flash 5 tutorial (and listed above), which will not work with Flash MX because the start executable is not in the fscommand dir, but in the Windows path.

Jesse
07-12-2002, 03:24 AM
The link I posted above notes:
Note: exec is not capable of opening a specific file with an application, just the application itself. One way to open files is to use
exec to launch a Windows batch (BAT) file or Macintosh AppleScript file that then opens files in the desired application. A
third-party tool that can open specific files on Windows without using batch files is available from Flashjester.
I didn't consider using a BAT file but that may well work.

sensoria
07-12-2002, 01:05 PM
Jesse-

Thanks for the help. I see your point now about not being able to execute a specific file, only the program, which of course cannot reside in the fscommand subdir. I think I was getting a little confused after looking at so many different posts on the subject.

Not much of a PC person, but I'll take a look at the batch script solution and see if I can work it out. From what I recall of the post, it didn't look too difficult.

I may also reinstall Flash 5 and try to go that route.

Thanks for the help!

Ron