PDA

View Full Version : FLV playback problem


no_chocobo
07-23-2007, 07:03 PM
I'm working on intergrationg a flv video into an existing SWF on our website. I've got everything working locally (using publish preview); and all of my links in my ActionScript refer to files already on our web server.

The problem is that whenever I upload the swf file to the server, the flv doesnt load. Is this something with security? My code is:

on (release){
this.vid.loadMovie("http://www.stealthhydroponics.com/images/splash_vid.swf"); }


any help?

matbury
07-23-2007, 07:57 PM
I just had a look at http://www.stealthhydroponics.com/images/splash_vid.swf ... got nothing but a blank white screen. So I guess the problem is in this SWF.

briston
07-23-2007, 08:25 PM
i had the same issue a few weeks ago and the way if fixed it was by logging on to my server control panel and adding a MIME type for flv.

Type ".flv" as the associated extension and "video/x-flv" as the content type.

hope this helps.

b

no_chocobo
07-23-2007, 08:43 PM
the swf loads for meon all of the office computers.

Is there a trick to loading a flvplayer into another movie clip?

no_chocobo
07-24-2007, 01:02 PM
Any other ideas yet? I'm close to my deadline and still clueless....

matbury
07-24-2007, 02:20 PM
All Ican see on the link now is the SWF placeholder.

Itried looking at your HTML source code... It's blocked! I'd recommend having a chat with whoever is managing the server/security for this site. It could be the security that's cocking things up for you here.

matbury
07-24-2007, 02:22 PM
Another alternative - don't use the video component. Write your own code for the FLV playback. It's easier to do in ActionScript than MP3 players!