PDA

View Full Version : SWF w/ flv stops short in html file


tweaknee
10-04-2007, 11:56 PM
Greetings.
Anyone know why a swf file played alone would play out the whole file just perfectly... but the same file, when hooked up on a web page, stops the flv short at random places, usually with 5-10 seconds remaining, and goes back to the beginning of the movie? Sometimes the audio continues. And sometimes it does run through the video, but the rest of the movie is cut short. I thought flv and mc timelines were independent.

It's a short animation that plays a sequence of movie clips, and also has a Netstream class to play a video. I'm not using the component to control the movie but my own buttons, which simultaneously control the background clips.

I would think if there were some kind of timeline issue the problem would also show up in the swf when run independently. My guess is it's something to do with the streaming.

You might be able to view the files here: (how it SHOULD run - click on watch video)
http://myweb.facstaff.wwu.edu/~parryr/homepage_design/movie_lummi.swf

and here (with the problem)
http://myweb.facstaff.wwu.edu/~parryr/homepage_design/index.html

Any help at all would be greatly appreciated. I've seen some stopping problems addressed in the forum, but none having to do with html vs. swf playback. PS I tried having the video redone in 44.1khz as in another post, but that video will not play at all.
Thanks,
Rochelle

tweaknee
11-08-2007, 06:10 PM
Okay... so lots of views here and no answers.

I did figure out a solution, although it didn't answer why the behavior would be one way in a stand-alone .swf and another way when viewed as part of a web page.

So here's my fancy, high-tech solution:

Ready? It's really complicated.


I added a few frames at the end and put the stop action there.



That's it.

Weird, huh?