PDA

View Full Version : NetServices.as


harilalkm
02-04-2008, 09:25 AM
hai friends,

I have downloaded an sample from adobe/devnet .It's FMS based application.
It includes this code..

#include "NetServices.as"
#include "NetDebug.as"

But wen i run the file i got this message..

" Error opening include file NetDebug.as: File not found.
Error opening include file NetServices.as: File not found.
"
I have downloaded the actionscript remoting component
from here http://www.macromedia.com/software/flashremoting/downloads/components/


please help me to find the problem.

acolyte
02-05-2008, 07:54 PM
Hi harilalkm,

1 .) with what version of actionscript are you working as2 or 3?

with as 2 it should be mx.remoting.NetServices.as / the same as with NetDebug

so


#include "mx.remoting.NetServices.as"


or are you trying to use remoting with as1 ?

in my as2 classes i as usually write :



import mx.remoting.PendingCall;
import mx.remoting.Service;
import mx.remoting.debug.NetDebug;

harilalkm
02-06-2008, 05:44 AM
hi acolyte,
Thanks for your reply.
Actually i am using AS2 in Flash cs3.

I try both of your code..
The first code is not working.It shows the same error message.
But the second code works after commenting the include statements..
:)

regards