PDA

View Full Version : Print frame not using the #b bounding when called from fullscreen projector.


clarkie
04-11-2001, 08:52 AM
Hi Guys and Gals.

I am having a problem with the Print command and the fact that it seems to
produce different sixed print results when the SWF is run by itself and when
loaded from an already running projector.

Basically this problem is this:
I have set up the individual frames in seperate movie elements with a #b
frame for bounding and a #p frame containing the material for print.

These frames are targeted for print from another movie element using:
on (press) {
print ("printcvr", "bmovie");
}
where printcvr is the name of the movie element.

This all works fine when I export the SWF and run it in as a player. The
print frames pick up the bounding from the #b frame.

However the full package consists of 8 linked swfs.
1. Intro SWF - this is converted to a Projector and runs full screen
(Fullscreen, noscale)
2. Loads a nagivation SWF which contains the links to the 6 other swfs and
loads in place of the intro. This nagiavtion contains links to the
individual swfs which are loaded using.
on (press) {
loadMovieNum ("coilin.swf", 0);
}

3. Once any of the Swfs containing the movie elements above are called and
the print button is then pressed within these swfs the print frame prints
mini in the center of the screen, it seems to ignore the bounding.


I have hosted the swf files if you want to take a look.
http://www.geocities.com/sc532j/example.zip
(321Kb)
Run the file Six.exe
From the nagiavtion option choose Robbie O'Halloran.
Go to Artist CV
Choose Print
and voila.


Is it to do with the levels and how the other swfs are loaded?

The only workaround is to greatly exaggerate the scale in the print frames
so it prints at a normal size, but this seems to be a trial and error
process and will take ages. The package is for delivery on CD-Rom.

Any help very gratefully appreciated. The project is almost finished except
for this blasted thing!!!

Shane

sabines
01-18-2002, 09:41 AM
hi clarkie,
seems like none could help with your problem, i'm stuck with the same question now.
figured a way out yet?

Rupert
01-18-2002, 09:57 AM
Hi, I missed seeing the original post first time round. I remember having a similar thing on a postscript printer last year and it turned out to be a printer driver thing and not anything to do with my file. Have you both looked into the possiblity that it is being caused by something like that?

Cheers,
Rupert

sabines
01-18-2002, 10:25 AM
well, i tried it with diffeerent printers and computers, also non-postscript, and this has to work with standard settings.
i went for the scaling solution so far, not very elegant, but it works.

clarkie
01-18-2002, 12:33 PM
Hi Guys.

See next Post.

Shane

clarkie
01-18-2002, 12:33 PM
Hi Guys.

Sorry for the delay in getting back to you. Basically the problem is a bug and the workaround which I worked out (before I realized this was a bug) and posted on the Macromedia forum, became the Tech note (funnily enough).

The Tech Note is
http://www.macromedia.com/support/flash/ts/documents/allowscale_print.htm

You should be able to use this insted of scaling to get 100% quality. Macromedia do not seem to have fixed this yet.

Let me know if any Q's.

Regards,
Shane

sabines
01-18-2002, 02:17 PM
thanks a lot, that post really helped.