PDA

View Full Version : dawing lines with as2


ASWC
02-26-2008, 04:34 PM
Please review. Also, one of my example was supposed to load an external jpg but I wasn't able to make it work with the CMS for some reasons. both the swf and the jpg were correctly uploaded but the swf wasn't loading the jpg. I ended up creating a swf with the jpg inside it and that's ok since what's relevant is the code itself but still what did I miss?

CyanBlue
02-26-2008, 05:29 PM
Looking nice... Approved... Thanks... :)

As for the image not loading... That probably is the path issue... Jesse, does BASE directory property work???

ASWC
02-26-2008, 06:08 PM
Thanks a lot!

ASWC
02-26-2008, 08:21 PM
I had to correct a few little things and apparently that means somebody has to review again. Thanks in advance and if you could show me some comments that'd be great too!

Jesse
02-26-2008, 08:51 PM
The issue with external files not loading is a BASE tag issue. The CMS doesn't support BASE tags. I've told the creators about the bug but it's one of the few they haven't fixed. Within the WYSIWYG editor you can edit the BASE tag yourself to set the base directory to the correct directory. If you have any images, etc. in your tutorial right click those to see the correct directory which will be of the form:
/resources/content_images/X/
Where X is your Author ID number, as that's where we store all your uploaded files.

There's a new version of the CMS which we're going to migrate to in the next few months. We'll try and build this hack into that, and I'll get onto the CMS creators again to point out the issue.

Jesse
02-26-2008, 08:55 PM
PS - re-approved your entry. Thanks

ASWC
02-26-2008, 09:38 PM
Thanks a lot, and thanks for the comment! Finally I have one! ;)