PDA

View Full Version : Compatibility issues


garrettb
04-28-2008, 08:19 PM
Hi.
I'm using Flash CS3 and developing for Flash 9 and finally got my site working. Yippee!
Then I got a phonce call saying it's all messed up when my friend views the site.
They presumably have an older version of Flash Player installed.
Does this mean I have to redesign the site using ActionSript 2.0 for Flash 8???
If I change the publishing settings to ActionScript 2.0 and Flash 8 I get compiler errors: "The class or interface 'Event' cannot be loaded", and "The class or interface 'MouseEvent' cannot be loaded"
Please help urgently!
Thanks in advance,
Garrett

Freki
05-07-2008, 05:51 PM
Just recently had a prob similar - what I did to fix it - I brought up the settings and left the flash settings as AS3.0 and FP9. On the next tab marked HTML, I then checked the box that said Detect Flash Version. That way, anyone that has an older version of flash will either get the site as I want them to see it or they'll get a link that says Click here to download the latest version of flash.

Hope this helps!
Freki

EDIT: I may be wrong, but I think the only other option you'll have is to rewrite your code in AS2.0.