PDA

View Full Version : geturl in Netscape 4x on mac


craigmw
10-31-2002, 05:09 PM
Hey,
I'm trying to make a sniffer for a site. It's simple at this point with javascript refresh after 7 secs and a flash (4) sniffer that uses geturl to direct the user to the flash site.
Problem is on Netscape 4.7 with Flash 4 installed, the geturl command only seems to work with _blank and not with _self. I've also tried leaving the window property at the default with no luck.
I've tried relative and absolute urls. Both have worked with _blank but not with _self or the default.
This is how my code looks now:
getURL ("index.html", "_self");

Any suggestions?

crabcake
11-01-2002, 12:19 PM
It should work. I have Netscape 4.7 with Flash 4 on a Mac as a test environment, and this script will work. Sorry. :(

craigmw
11-01-2002, 05:07 PM
As I would expect it to. Yet I can't seem to get netscape to do anything besides open a pop-up window from Flash.
Could you go to my site (http://www.grolla.net) and see if you're redirected? It would be much appreciated.

Thanks,
-Craig

crabcake
11-01-2002, 05:18 PM
No, it just hangs on a background screen. It doesn't even seem to run your meta refresh. There must be soemthing else wrong. How are you testing to see if they have Flash 4?

craigmw
11-01-2002, 05:30 PM
Well so far I 've just been trying to see if they have flash at all.

All my sniffer does use the geturl command to direct them to the flash content. If I could get that to work I could focus on version detection, but I haven't gotten that far yet.

The logic is, if they have flash then the sniffer will be able to redirect them to my site and therefore the actual content of the site will work. If the flash doesn't load and direct them to my site, then the refresh should redirect them and tell them to get the flash plugin.

I'm highly dismayed that even the refresh isn't working. So all you saw was a background color?

crabcake
11-01-2002, 06:23 PM
Yes, but the meta refresh tag doesn't work on all browsers, only on some. You could add a JavaScript detect for good measure. I made a test movie with a get url in it, and the published file worked just fine in Netscape 4.7 on the Mac. The only command I entered was

getURL("http://www.cnn.com");

and it launched the page OK.

I think there may be something else wrong.

craigmw
11-01-2002, 07:00 PM
Yes, I'm what really curious what is wrong.

How odd that the meta refresh worked on my netscape but not on yours. And the Flash redirect worked on yours but not on mine.

Trouble is I'm not really sure where to look at this point.

I suppose I can try another method of Flash detection, but if I'm having trouble with something simple like geturl, I'm still pretty irked.

Thank you for your help so far. It's been much appreciated.

-Craig