PDA

View Full Version : audio breaking when more than 15 movies on page. revision 124


leefentress
09-22-2008, 05:03 PM
Has anyone else noticed this problem? I've been using these flash mp3 buttons, Wimpy Buttons, from wimpyplayer.com for playing audio samples of cd tracks on a website for a record label. If there's more than 15 of them on a page, the audio breaks and won't play from any of them in any browser except for IE. I've noticed this in revisions 124 and 115 of Flash 9. I downgraded to revision 47, and it restored the functionality. I've tested this on multiple computers. Some XP and some Vista. On Macs it seems to be working fine with revision 124 in different browsers. I've also noticed this problem on other websites that are using various different Flash movies for playing audio--when there's more than 15 Flash movies on the page, the audio breaks.

Rossman
09-23-2008, 04:54 PM
This is possibly the bug with ExternalInterface and IE....if so, try inserting the SWF's into the page using SWFObject, I remember those guys sorta patched that bug previously.

leefentress
09-23-2008, 08:55 PM
It seems that it works fine in IE. The problem that I've noticed has been happening in browsers like Firefox, Opera, and Safari.

senocular
09-23-2008, 08:58 PM
This might have been fixed in the latest 10.
http://labs.adobe.com/downloads/flashplayer10.html

Rossman
09-23-2008, 09:34 PM
It seems that it works fine in IE. The problem that I've noticed has been happening in browsers like Firefox, Opera, and Safari.

Oops, sorry, I misread your post!