PDA

View Full Version : Sending data to ASP


Teddy_Newbie
04-09-2009, 04:48 AM
Cota, Can u please help me.... I need a code that successfully sends a value from flash to asp(C#) and asp should recieve that value.. currently, i'm using this code in the first frame(PS: i jus have one frame and one layer)..

var myData:LoadVars = new LoadVars();
myData.test = "Test";
myData.send("Default.aspx","","POST");
stop();

And in ASP, I retrieve it like this..
string test = Request.Form["test"];
Response.Write(test);

This works perfectly fine.. I get the output on asp. But flash is sending value continuosly to asp, and hence the page is loading continuously. I tried various options like disabling loop, creating a new frame and placing stop() there etc. None of these work. i have tried other methods of sending values to asp from flash. This is the only that sends value successfully but looping indefinitely. I have been stuck with this for more than a week now. Please help:-(

Cota
04-09-2009, 02:38 PM
Is it in a loop? Or is the frame itself looping? a stop action could be useful.

Teddy_Newbie
04-10-2009, 02:52 AM
The code is not in a loop.. I undestand that the frame is looping indefinitely.. these are the only lines of command in action script.. and the asp code is in page_load.. I don knw y.. but stop() is not working.. i have explicitly removed looping too(while publishing as well as in the <object> tag in asp .. but none of these methods work.. :'(

Cota
04-10-2009, 02:03 PM
Could you attach the files? I usually put the stop as the first action. Unless the movieclip holding this code is inside another movieclip thats looping.

Teddy_Newbie
04-13-2009, 04:38 AM
Hi cota. I 'm attaching 3 files.

1) The file LoadVars is the one with the looping issue.

2) I found a different way to send values to asp.net using ExternalInterface.call(). When i use the file EI.fla, the js script function is getting invoked and the value gets passed to asp.net.

3) If i use the file Local_SO.fla which has creation of shared objects and sending that variable to asp.net, the js function is not getting invoked.

Please Help!!

Thanks in advance..
Teddy