PDA

View Full Version : I've got the bad button blues...


kaska
04-28-2001, 09:00 PM
I've searched the forum and followed all of the tutorials that I thought would help (Jesse, you're my new hero! :) ), but I still can't figure out what should be a very simple problem. (I'm an EXTREME newbie using F5)

Problem:
within my main timline, I have a movieclip "bubs2" which houses all of my animated buttons. They each use the getURL function, and have sound on mouseOver. HOWEVER, when I test the movie, my buttons seem to have forgotten they're buttons at all, i.e. no sound, no function, just bubbles. I assume I my problem is in the path, but I can't figure out where...

or should I just give up and start using my Flash "Advanced" (WTF was I thinking??!) book as a doorstop?

-Kaska

[email protected]



PS: as I was searching the posts, it seemed to me that oct10 was having the same problem, maybe...?

seventhmonkey
04-29-2001, 02:46 AM
an example of the code you are using would be helpful...

:)

kaska
04-29-2001, 04:00 AM
There really IS no code- just a getURL function attached to the buttons, which worked when I was using it on the main timeline in another movie...

Jesse
04-29-2001, 07:19 AM
If they're buttons then your mouse will turn into a hand when you move the cursor over it... mkae sure you've used buttons and not movie clips with onClipEvents on them...

Cheers

Jesse

kaska
04-29-2001, 07:18 PM
first of all, thank you to everyone that's been so kind as to respond. Second of all, even though I've been trying any and all suggestions I've found, nothing is working yet. If anyone happens to have way too much time on their hands, you can find the .fla and a longer description of my inadequacy at http://briefcase.yahoo.com/kasienko

-Kaska

seventhmonkey
04-29-2001, 11:20 PM
kaska that is very strange :(

Jesse
04-30-2001, 05:29 AM
The problem (as always with these sorts of problems) is in the first frame of the Blue Ball MC - the start-drag command. If you're dragging a button you can't click another button. You will have to adapt the code somehow so that the blueBall mc is moved to the _xmouse and _ymouse rather than being based on a startDrag.

Cheers

Jesse