PDA

View Full Version : ReferenceError and VerifyError problem in simple movie


theMonitor
11-24-2009, 10:04 AM
I wonder if anyone could help with a multiple error message problem I'm getting?

I've made a very simple movie that doesn't use any external classes - all it does is animate a series of movie clips (it's real eye-candy stuff). There are a couple of 3D transformations, but apart from that all it uses is basic shapes and classic tweens. Oh, and there's an embeded sound file.

Now, when I export it as an swf there's no problem. Neither is there a problem when I play the swf embedded in a browser, or an exe version of the file. But when I try to play the swf in the standalone player (i.e.by simply clicking the swf file icon), I get a series of error reports:

VerifyError: Error #1033: Cpool entry 18 is wrong type.
ReferenceError: Error #1065: Variable theMovie_1 is not defined.
ReferenceError: Error #1065: Variable txtLinksFlyIn_25 is not defined.
ReferenceError: Error #1065: ...

...and many more 1065 errors, each referencing a MC I've used in the movie (but with an underscore and a number appended). Then, when these messages have been cleared and the movie plays, the clips are not tweening as they should do, and the sound file starts to repeat before it's finished.

I've done some Googling and the consensus seems to be that this problem can be caused by inaccurate declaration of external classes. However, as I said, I'm not using any classes here - it's all very basic timline-based stuff (I'm only using CS4/AS3 because I wanted a 3D transformation).

There's a client waiting on this, so could anyone be kind enough to let me know what might be causing the problem, and suggest a cure?

Thanks in advance...