PDA

View Full Version : [CS3] Problems in using flvPlayback component


scitrs
05-28-2010, 01:35 PM
Hi Everyone
I am trying play an .flv file to a web site using flvPlayback component in CS3. The file plays well if give local path but when I give a web URL address it returns an error 'Error Opening URL .....', though the .flv file is present in the webserver. I also uploaded AC_RunActiveContent.js file to the server.
Thanks in advance.

Navarone
05-28-2010, 01:52 PM
There could be several reason why this isnt working. Probably if the flv and the flash file are not located in the same directory on the server then the component has trouble reading the URL. Do a little research into Sandbox violations and security violations. What exactly does the error say?

scitrs
05-28-2010, 02:37 PM
There could be several reason why this isnt working. Probably if the flv and the flash file are not located in the same directory on the server then the component has trouble reading the URL. Do a little research into Sandbox violations and security violations. What exactly does the error say?

Thanks for your quick response, but the .swf file and .flv files are in same folder , I even copied the flvplayer skin file +

scitrs
05-28-2010, 02:41 PM
There is no error message , only Flash Player appears , but no play back
Thanks.

Navarone
05-28-2010, 02:42 PM
Here is snippet of code I use. My videos are in a folder called videos maybe this will help. In this case the id is the name of the video like myVideo.flv or myVideo.mp4 . I assume you are using AS3 code?


trace("id = "+id);
import mx.video.*;
my_h264plybk.contentPath = "videos/"+id;
var listenerObject:Object = new Object();
listenerObject.complete = function(eventObject:Object):Void {
trace("Elapsed play time at completion is: "+my_h264plybk.playheadTime);
//my_h264plybk.play();
_root.gotoAndPlay("aboutbdi_understand");
};
my_h264plybk.addEventListener("complete",listenerObject);

Navarone
05-28-2010, 06:26 PM
I would double check the your path and make sure its correct. If both the flv and swf are in the same folder it should work.

scitrs
05-29-2010, 05:12 AM
Thanks Navarone
I checked at the Adobe site and came to know that .flv file needs to be registered at MIME type at Web server. I am trying to sort out the issue with my webhosting compnay.

Again the .swf file, the html file and the .flv files are in the same folder, also the same works fine if I play the file at my local webserver i.e //localhost.

My test files are at http://scitrs.com/two.html , http://scitrs.com/two.swf , http://scitrs.com/test.flv , you can see the path is same for each file.

Again thanks for you support.
Regards.

scitrs
05-29-2010, 07:34 AM
Hi Novarone
The problem has been resolved , the web hosting company registered the .flv file type in MIME type.

Thanks for all the help you provided in solving this issue.

Regards