PDA

View Full Version : need help with amfphp remoting


viesturs
03-25-2003, 07:30 PM
I installed flash remoting component and also PHP Remoting Gateway implementation from amfphp. Al the PHP files in place, when i run the example FLA files i don't get any return.

in NetConnection Debugger window i get following in details

EventType: "Status"
MovieUrl: "file:///c|/Downloads/fr/talk.swf"
Source: "Client"
Time: 1048625342156
Date (object #1)
....."Tue Mar 25 22:49:02 GMT+0200 2003"
Status (object #2)
.....code: "NetConnection.Call.BadVersion"
.....description: ""
.....details: ""
.....level: "error"


when i call flashservices/app/Gateway.php there is no php errors
It all acts as everything is correct by Jesse Stratford's tutorial.

any idea

Emanweb
03-25-2003, 08:02 PM
I am having problems also. I couldn't make it run on my server (freebsd/apache/php) yet. But this seems a great tool if could use as Remoting for CF MX. I will try more later tonight and then I let you know.

viesturs
03-25-2003, 08:22 PM
I just checked everything works on my local windows/apache/php,
couldn't get it to work on mandrake/apache/php.

Emanweb
03-25-2003, 08:40 PM
humm... then I think it could be something related to the file locations and the famous issue of "/" and "\" between windows/linux OS.

Jesse
03-25-2003, 10:41 PM
Since AMFPHP is still new I'm no expert on the rror messages but that error is generally reported when the function I'm trying to call doesn't exist or the arguments are wrong.
It also failed when I have CF installed (remember I say in the tutorial you need to uninstall it).

zoomfreddy
05-07-2003, 05:38 AM
that error is related to the gateway path on the fla or on the gateway.php file, i had a hard time to get Jesse's tut working because of that, and tweakin the path solved it fot me...

my config:

OsX 10.2.5, apache 1.3.26, php 4.1.2, mysql 4.0.12, amfphp 0.51...yeah, finally i can develop without a Pc on my way at all!!!...well, Pc gets on my way only to serve online...hehehe...the slave server :)

alernon
06-05-2003, 08:46 PM
I can't seem to get remoting to work as well. the phpinfo(); tag works, and I don't get any errors accessing the gateway, but when I try to access the test_remoting directory I get a mime-type error. It thinks the php file is of the type x-amf ?!? All other php pages load fine

zoomfreddy
06-06-2003, 04:40 AM
are you accesing directly the php file?, and...is the browser trying to download the php file?
if so, that's ok, the file is working ok, try with the swf...

alernon
06-06-2003, 01:29 PM
Yeah, I was accessing the php file. Heh. Now I feel pretty dumb.

dr.swank
06-07-2003, 03:37 PM
hey zoom, I am using a similar setup and cannot get the gateway path to work. could you post the path you put into the gateway.php file on your setup??

thanx, Dr.s

zoomfreddy
06-08-2003, 10:45 PM
on the gateway.php file:
<?
// Include AMFPHP Gateway...
include "../flashservices/app/Gateway.php";
// Create a new Gateway Object which will handle communication
// between PHP Remoting and Flash
$gateway = new Gateway();
$gateway->setBaseClassPath("services/");
$gateway->service();
?>
on the fla file:
NetServices.setDefaultGatewayURL("http://localhost/~zoomfreddy/remotingBB/simple_gateway.php");


and every file is inside "remotingBB" folder.
This settings are for Jesse's remotingBB example, also you need to change the conection strings"host","user"and"password" on each php service file, and create the database and tables on Mysql).
also, check out for strange characters(garbage) on the php files,if they exist, remove them.
hope this help.

dr.swank
06-09-2003, 09:09 AM
zoomfreddy, thanx, I will give it a whirl and post back if I have any trouble. thanx again, dr.s

alernon
06-09-2003, 02:34 PM
Anyone know a good intermediate PHP tutorial on the Web? Everything I find is pretty basic and doesn't get into objects and such. Any help would be appreciated.