PDA

View Full Version : Heeelp


eyezberg
04-01-2003, 07:14 PM
Jesse,
thanks for the tutorial on amfphp.
I'd like to get sephiroth's iage gallery to work, but no deal!
I tried everything i could think of, your test_remoting seemed to work (at least i got a blank page without errors after trying with the wrong path to the main files 1st, which did echo a path error message), but only traces the 1st three lines, but nothing returned from php, then i tried with both the files from amfphp v050 and 051, and sephiroths downloadables, and the app just "hangs and nothing happens, then i tried to call the included gateway.php directly, and the browser openend a download box for the script, same happened with the "discovery.php" included with amfphp..
I really don't know what else to try, also i was wondering if the file in the services folder stays in that folder in the same folder as the gateway resides, or has to be moved into the "services" folder in the flashservices folder..
I'm confused and helpless..thanks in advance for any further informations to get this working.
I have root(public html), in that one folder with all the amfphp files called flashservices, then also in root a folder called amf, and in that one different folders with your test app, sephiroths gallery, and the example, and nothing works:
http://www.flasheyez.com/amfphp/imageBrowser/

(if you try to call http://www.flasheyez.com/amfphp/imageBrowser/gateway.php , for me the browser tries to download the script!?..)

Jesse
04-01-2003, 10:37 PM
The download prompt is not unusual, as you're creating a new Object and when you download the file it offers you, you will find it's a binary format AMF file which means things are working. I think the likely problem is still a pathing issue. I can't find your Flash services directory. I personally keep it in the public_html section of my site.... Not sure if you have to do that for it to work... If all else fails, put a copy of the flashservices directory in the directory your example is in and change the paths accordingly.

Jesse
04-01-2003, 10:39 PM
Actually, I did find it at http://www.flasheyez.com/flashservices/ . Since the gateway file doesn't give me any errors I'm incluned to think you still have a pathing problem. These things are hard to diagnose externally