PDA

View Full Version : Form and special characters


simonboris
12-23-2003, 10:22 AM
Allright, i have built a form that send information via email using asp.

I use 'system.useCodepage = true;'
First a get the information for the form via xml, UTF-8 encoding to get special characters like etc...

No problem here, it work fine.

// - - - - - -

When i click send, i send all the variable to an asp page.

In the asp page, i use for exemple:

Name = Request.Form("aName")

It work's fine and send me an email with Name and it's value using a email sender script.

When i check my email, i see weirds charachter that replace the ' etc..'. Instead of getting for exemple:

, i get éé !

What should i do the get the right data in my mailbox. Is it a asp or flash problem ?


Have any idea, please share.

simonboris
12-26-2003, 06:58 PM
allright, i know what is my problem but i am not able to solve it.

I import data in flash via xml, in UTF-8 encoding, and send data in the same encoding format.

I take the information that a user provide using a form and send it to my email box (Outlook email 6). I get the email with the information but i don't see special characters. They are replace by weird letters.

i have called the company that host my website. They have provided me with a ASP script that work with 'Microsoft CDO for NTS 1.2.'

I need to encode my email in utf-8 so i an read the special character. They don't know how, i don't know too.

have try to put in the <head></head> tage (my email is in html):

"<meta http-equiv='Content-Type' content='text/html;charset=UTF-8'>"

But it still does'nt work.

Is there someone here that know how to tell Microsoft CDO for NTS 1.2 that the email i will send will use utf-8 encoding ?