PDA

View Full Version : Importing .mov files into Flash


oaker
01-25-2004, 07:05 PM
Hi,

I imported a .mov file into my flash movie. When I play back the flash file, there is no sound. The video I imported had sound. What am i doing wrong? This is driving me nuts.

oaker
01-25-2004, 07:59 PM
i converted the same file to an .avi and it works fine. However I still want to use the .mov instead of the .avi

Not sure why the .mov would not work properly.

oaker
01-25-2004, 09:06 PM
gawd, what a pain. Had to get the .FLV converter for quicktime, then re-export all my .mov's to .FLV's. Works good now, but what a pain.

farafiro
01-26-2004, 03:42 AM
what is the version of the QT u have installed in your PC??
see Working with Video in the Using Flash.pdf file that comes with flash

oaker
01-26-2004, 11:21 AM
im using Quicktime Professional 6.5 on a MAC running 10.3.2 Panther.

farafiro
01-27-2004, 04:54 AM
this is from Using Flash.pdf file that comes with Flash MX 2004, Chapter 10 "Working With Video"About file formats for imported video
If you have QuickTime 4 or later (Windows or Macintosh) or DirectX 7 or later (Windows only)
installed on your system, you can import embedded video clips in a variety of file formats,
including MOV (QuickTime movie), AVI (Audio Video Interleaved file), and MPG/MPEG
(Motion Picture Experts Group file). You can import linked video clips in MOV format.
Flash documents with embedded video can be published as SWF files. Flash documents with
linked video must be published in QuickTime format.

oaker
01-27-2004, 12:13 PM
yeah, that would be great except flash gets rid of the audio on my .mov's when I import them. I went through all the settings, and even in the preview window the movie plays with sound, then I export and boom..its all gone. Who knows.... Anyway, using .flv and the media components works better anyway because it allows me to stream from an external file. Thanks for the help. :)

farafiro
01-28-2004, 12:51 AM
go get the pdf and read this chapter
would make u understand things more

oaker
01-28-2004, 08:33 PM
will do..thx.

jubei
01-28-2004, 11:58 PM
I found they way to do it is to embed the files initially, so you can place animations or titles or whatever over the top of it and make sure it all lines up. Then, delete the embedded file, reimport it but this time link to it. Then when you export it, all the sound will be there.

It worked for me, anyway :)

farafiro
01-29-2004, 12:42 AM
jubei
there are some files that lose the sound forever when u import it
this is by MM docs

jubei
01-29-2004, 03:54 PM
Oh, ok. I guess i should be thankful that it worked for me then. I had hoped that with all the new movie stuff in MX2004 Pro, that sort of problem would be sorted.

dbonneville
07-02-2004, 03:53 AM
I tried what you discovered - I got the embedded version in there so I could line up some words over the video. I then deleted the embedded file, and then linked the .mov. When I play, there is no video?? How did you solve this?

Doug

farafiro
07-04-2004, 06:51 AM
don't delete the embeded file

dbonneville
07-05-2004, 06:03 PM
Even if I don't delete the file, .mov or .avi, I still get no sound. I double checked export settings, and sound is enabled as default.

Doug

farafiro
07-06-2004, 05:37 AM
ahuh
ok, in MM documentation they say that some files might have this problem
either read it or look for it online @
http://livedocs.macromedia.com/flash/mx2004/index.html

vilehelm
12-08-2004, 06:42 PM
Check when you're creating the video file originally(imovie, finalcut or exporting it in QT Pro...etc.) that you have the Audio uncompressed. If you are using mpg4 or a couple of others, flash will not support it.

Flash will compress the audio. Hope this is an actual answer to your problem.

zoe
03-24-2005, 04:19 PM
Hi,

I imported a .mov file into my flash movie. When I play back the flash file, there is no sound. The video I imported had sound. What am i doing wrong? This is driving me nuts.

I am having the same problem. When I import the flash quicktime movie into flash the sound disappears. Its driving me mad too. Did you find a soultion ?
Please let me know.

http://www.actionscripts.org/forums/newreply.php3?do=newreply&p=203574#

noelbon70
03-24-2005, 04:27 PM
Hi,

I imported a .mov file into my flash movie. When I play back the flash file, there is no sound. The video I imported had sound. What am i doing wrong? This is driving me nuts.

I read somewhere that sound doesn't come in from movs if they are imported. That still doesn't makse sense but I could not get it to work. Drove me nuts. I don't have all the details about how I solved it - was some time ago, but I found another solution:

I upgraded (on my PC) Quicktime for 29.95. It exports / converts movs to all kinds of things. I exported the mov to an flv, and imported that into Flash. Worked like a charm, and gave me a chance to tweak the compression and overall quality.

That said, there is some way to get movs into Flash WITH the sound, but for some reason I was never able to do it. I have fla's on my PC right now, from someone else that didn't even know what they were doing with Flash, and the import movs work.

Doug

farafiro
03-27-2005, 05:59 AM
Its driving me mad too. Did you find a soultion ?
Please let me know.
lol
nop guys, it's written in Flash MM's documentations that this may ocurs and then nothing, so u should accept it as is
;)