PDA

View Full Version : problems publishing with flash remoting


campbela
07-04-2004, 03:27 PM
I'm having problems with remoting when I try and access my site using a URL (eg. www.mysite.com within Internet Explorer), where although the flash movie is displayed, data is not being displayed & hangson the first invocation of a flash remoting call.
However , if I try & invoke the site directly by clicking index.htm (from c:\inetpub\wwwroot\mysite\index.htm), or clicking the (.swf) directly, everything works fine & data is displayed as intended.

Generally throughout my app, visitors/partners are able to read/write/delete data held on the SQLServer database strictly through the use of SqlServer stored procedures delivered via ColdFusion web services linked to Flash Remoting. Because of this, I believe that the relevant Coldfusion data connection can safely use the nominated userName/password associated with a max.empowered SQL server user - is this permissable from a security viewpoint?
Have I missed something silly, in the publishing or setup? I've made sure that the ColdFusion data connection is verified OK, and that it authenticates against a well-empowered user within SQLServer2000.

To try & figure out where the problem is, I have tried to access the NetConnection Degugger from Windows>otherPanels when editing the *.fla file. However, when I run "Test Movie", the panel disappears,and cannot be viewed despite my checking of all the available "preference" settings.
I've scoured the internet for help in setting up & using NetConnDebugger & cannot find anything that works! I've also consulted my copy of Jody Keating's "Inside Flash MX" where it seems that all you need is:

1) to ensure that "#include "NetDebug.as" is included
2) to open the debugger, select Window>NetConnect Debugger
3) if the Debugger is open when you test your movie, then the events pop up as they occur.
4)...then it leaves you hanging with "The debugger is a chapter unto itself, so we will leave our introduction as is"

Admittedly this relates to Flash MX (rather than Flash MX 2004), but (2) & (3)of the above doesn't seem to relate
Can anyoneexplain why I cannot access the NetConn debugger from the (.swf), rather than (.fla)?

Please can anyone help, as it's taken me 4 years to get to this stage -& I'm frustratingly close to the finish!

Regards
Alex

-------------------------------------------------------
My environment
-----------------------
Web Server m/c has:

* Flash MX 2004 movie (published as ActionScript1.0, Player 6), embedded within a set of
* Dreamweaver-generated HTML pages
* Coldfusion 6.1 (std.production version)
* Flash remoting
* IIS(vers.6.0) as the web server, & therefore using ColdFusion as the Application Server.
For IIS, I used the following permissions for Users - with these being greyed, but "ticked":
a) read & execute
b)List folder contents
c)Read permissions

and the associated database server m/c runs SQLServer2000(Std.Edition)

Other relevant code:
===================< from within ChoiceIT05A.fla >=============
this.init();
function init(){
if (this.inited != undefined) return;
_root.ldgShopper.setActiveState(true);
this.inited =true;
stop();
//place other initialisation code here...
// Include the Required NetService class files
#include "NetDebug.as"
#include "NetServices.as"
#include "DataGlue.as"

// connect to the Flash Remoting service provider
trace("isGatewayOpen is:" + isGatewayOpen);
if (isGatewayOpen == null) {
// do this code only once
isGatewayOpen = true;
// Make the Gateway connection
NetServices.setDefaultGatewayUrl("http://www.choiceit.com/flashservices/gateway");
// --------line below commented out as using IIS for webserver , and CF as Appln.server in production environment
//NetServices.setDefaultGatewayUrl("http://localhost:8500/flashservices/gateway");
gatewayConnnection = NetServices.createGatewayConnection();
//--------:below refers to c:\inetpub\wwwroot\ChoiceIT\ChoiceITsql.cfc
choiceITService= gatewayConnnection.getService("ChoiceIT.ChoiceITsql", this);

=============<from within HTML calling page>============================
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="800" height="600">
<param name="movie" value="ChoiceIT05A.swf">
<param name="quality" value="high">
<embed src="ChoiceIT05A.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" width="800" height="600"></embed></object>
-----------------------------------------------

AJ in LA
07-21-2004, 05:39 PM
campbela,

Did you find a solution to your issue? I am facing the same dilemma.

Thanks!,
AJ in LA

antiHero
03-06-2008, 06:36 PM
Have you tried adding a cross domain xml sheet to your web root?

Try this:
create a xml file in your web root named crossdomain.xml

xml code:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">

<cross-domain-policy>
<allow-access-from domain="yourdomain.com" />
<allow-access-from domain="*.yourdomain.com" />
<allow-access-from domain="www.yourdomain.com" />
</cross-domain-policy>

I had this problem as well, but adding this xml fixed it for me.

deepakkarma
12-18-2008, 09:06 AM
IP=192.168.0.14
Log Level=Error
Log File Size=1048576

save in frconfig.txt in ur bin directory of ur project.
change here ip address to ur machine ip address. and then run


reply me. at
[email protected]