PDA

View Full Version : Cant't type in input?


G-Rard B
11-10-2004, 01:01 AM
Hey, I've got a problem. I've finally made a sript that can email people from flash. Now, I'm trying to put it into a site that's going to be made completely from flash. There's just one big problem. I can't type in the input text feilds! I've tried changing the color of the font, etc. I've copy+pasted the same exact actionscript, MCs, etc. into a new flash page, and then it works! Also, the button in the form doesn't show text in the site, but it does in it's own seperate flash movie. I've even tried publishing the working version and importing it into the site, but it doesn't show the button (it shows it like it does in debug mode) and I can't type. Any ideas?

G-Rard B
11-10-2004, 09:50 PM
Oh.....I guess my Flash MX 2004 copy is just messed up :(

brolife
11-10-2004, 11:09 PM
are your input boxes under a mask?

if they are you wont be able to type anything into them.

G-Rard B
11-11-2004, 01:42 AM
Yes, in fact they are! Thanks, man! I'lll try to find a way to fix this :)

petefs
11-11-2004, 05:38 AM
I'm not sure about input fields under a timeline mask, but when a mask is applied via actionscript setMask() you can still type into input fields under it. If the font isn't embedded, however, you'll have problems. non-embedded dynamic/input text-fields won't show text under a mask.