PDA

View Full Version : connection's fine, but no result back !!


_marabout
11-13-2004, 09:36 AM
Hi,

I've tryed to run some of the AMFPHP samples found in the tutorials on various sites and it always fails to send results back.

I've solved various problems such as the BadVersion one, so everything seems to go fine, the NetConnection Debugger reports the connection runs ok, the remote call too, but then nothing happen, no error, and the _result callback function is never ran...

Actually, the remote function is never called : I've tryed to log the services methods and the conclusion is that there are never ran.

I've struggle to understand it all the day long but there I didn't find a lot of information about AMFPHP on the web... for example, is there a doc that explains all the possible values in the MethodTable array ? I didn't find such a thing on the AMFPHP website.

So thanks for any suggestion !

_marabout
11-14-2004, 10:55 AM
I finally found a solution : it seems that something went wrong with the amfphp files when copying to my "flashservices" folder. I removed every folder (app, exceptions, io, sql, util) and copyed them back from the amfphp unzipped source folder, and it worked.

Serious problems often have stupid solutions :)

Zárate
11-16-2004, 04:12 PM
Hi!

I'm having the same problem too. I´ve tried what you've done, but the problem is still there.

From every tutotial i'm trying, i'm getting the same in the debugger:

----------------------
DebugId: 0
EventType: "Status"
MovieUrl: "file:///F|/www/pizza/pizzaServiceClient.swf"
Protocol: "http"
Source: "Client"
Time: 1100625075828
Date (object #1)
....."Tue Nov 16 18:11:15 GMT+0100 2004"
Status (object #2)
.....code: 256
.....description: "This user is not does not have access to order"
.....details: "F:\www\flashservices\app\Executive.php"
.....level: "User Error"
.....line: 295
-------------------

It seems some kind of configuration problem. Any ideas???

Thank you very much!

petefs
11-17-2004, 10:46 PM
remove or comment the lines in your method-table regaurding 'roles'

Zárate
11-19-2004, 08:11 PM
Um.....

Sorry, i don't understanf what do you want i try.... ¬_¬ Thanks anyway, i keep searching.

Bye!