PDA

View Full Version : ERROR: NetConnection.Call.BadVersion


sunonepp
01-20-2005, 04:51 AM
does anyone know what causes NetConnection.Call.BadVersion error?
I testing connect flash to servlet, but got this error in netconnection debugger.
Thanks

sunonepp
01-22-2005, 01:18 AM
I checked almost all the info online but still cannot get the answer. So what is wrong with remoting and servlet???
Does any one suucessfully connect servlet using remoting???
If not, I think flash remoting still have a long way to go....
:(

petefs
01-22-2005, 05:12 PM
Here's a troubleshooting checklist for you.
http://www.sephiroth.it/phpwiki/index.php/Call.BadVersion

sunonepp
01-23-2005, 12:50 PM
But that one is for php, right? The one I testing is servlet.

atari8
02-11-2005, 10:08 PM
Its probably caused by the fact that your servlet is giving bad output content.
check to see that you have no spaces or extra output being printed in the Response stream, other than the remoting response.

iliad2b
02-27-2005, 09:43 AM
i am not to sure about this, cuz i am soooo new to amfphp.......


but,


i was having the same problem "NetConnection.Call.BadVersion" when i tested my movie in Flash.

when i dragged and drop the "RemotingConnector" from my UI Components to my stage, all of a sudden i no got my error.

i don't know how else to test this but, just thought i would mention it.

Jon Emerson
07-21-2006, 08:18 PM
Hi guys,

I too was getting the BadVersion error today, but for a completely weird reason! My back-end system was responding to the AMF request with an HTML error message, which obviously was invalid. But apparently Flash Player still thought it was an AMF response, couldn't parse it, and gave the BadVersion error!!

Jon
http://blogs.adobe.com/jon.emerson/