View Full Version : resizing entire movie

12-05-2001, 02:08 AM
hello there,
Just wondering how you enable the .swf file to automatically resize itself according to the browser window..?

"Don't worry, I checked her out about a week ago, make sure she was top quality! And I'm as healthy as a horse, not a drip!"
Jim Carey:D

Billy T
12-05-2001, 02:28 AM
in the publish settintgs in the html tab set the dimensions to 100%

12-05-2001, 02:48 AM
fscommand("allowscale", "true");

would be another option

12-05-2001, 02:50 AM
Thankyou, but can you be a bit more specific, are the publish settings in Flash or Dreamweaver?

" 'Dry land is not a myth, I've seen it.' Kevin Costner, Water World. I don't know what all the fuss was about, I saw that movie 6 times!! It RULED!!"
Jim Carey

Billy T
12-05-2001, 02:59 AM
in flash

file - publish settings

12-08-2001, 11:14 PM
Is that all I need to do as it's not working?
Where would - fscommand("allowscale", "true"); - go?

12-08-2001, 11:45 PM
just put the fs command script in the first frame of ur main timeLine.

12-09-2001, 12:54 AM
Taldo, thats only possible for projector movies, not for the web. ;)

Billy T
12-09-2001, 12:59 AM
I use fscommand("allowscale", "false"); for the web all the time

12-09-2001, 01:06 AM
allowscale is not only possible but sometimes annoying on the web. the same is true with fscommand ("fullscreen"/"highquality") and a whole bunch of other fs commands as long as u pusblish with fs command selected in the publish settings

Billy T
12-09-2001, 01:09 AM
why annoying?

12-09-2001, 01:11 AM
All you need to do is edit your HTML file. Where it asks for a size give it a percentage rather than a pixel dimension.

In other words change:
HEIGHT=550 (or whatever)
HEIGHT=100% (or whatever)

Hope this helps,


12-09-2001, 01:14 AM
Please excuse me, it's 3 am here ;)
i was thinking of Fullscreen true, which some dudes have been asking me about..
maybe time for the bed now...

Billy T
12-09-2001, 01:17 AM

good night;)

12-09-2001, 11:17 PM
OK guys, now I'm a little confused...
Changing the dimensions in my html from pixels to 100% didn't work, nor did "allowscale", "true"
Taldos, why are those fs commands annoying? and are you saying I need to have fs commands selected in the publish settings?
If anyone has got this to actually work, I'd love to know which method you've used:D
Many thanks!

Billy T
12-10-2001, 01:30 AM
setting dimensions to 100% has always worked for me

12-10-2001, 02:56 AM
would you mind copying the code so I could see exactly what it's like, eg, where should the inverted commas be? Does it matter if the .swf is in a table or not..? Sorry, my html is poor!
I assumed I'd just have to swap - "600" for "100%", but it didn't work. Any help is greatly appreciated.

Billy T
12-10-2001, 05:22 AM
you dont need to know any html - in the flash publish setting click on the html tab and change dimensions to 100%


12-10-2001, 08:30 AM
Sorry, someone mentioned changing the dimensions of the .swf in my html page....
changing the publish settings to 100% in flash was the first thing I tried...???!!! Is there anything that's critical for it to work? Even if seems obvious to you... it may be something I've overlooked..?
Again, I appreciate any help.

Billy T
12-10-2001, 08:35 AM
nothing that I can think of...

do a test with a movie with just one image in it or something - maybe there is something strange with the file you are working on...

actually I thought a flash movie would resize in the browser by default...

good luck

12-10-2001, 10:17 AM

Resizing a Flash movie in the publish settings and resizing it in the HTML code is exactly the same thing.

It does work because it just does alright? It can't not. So, there must be something that's stopping it. Have you placed the code inside a fixed size table in HTML? Is it in a frame? Is there some actionscript code that is specifying exact sizes?

Give us a link to follow so we can see what you mean. Exactly how is it not 100% of the browser window?

What browser are you using?

It's not margins you're talking about is it?


12-10-2001, 10:41 AM
Yay!! I didn't realise that when you hit publish it actually creates an html page! I'd alwayse just inserted the .swf file that's created when you test the movie.... anyway thanks!

12-10-2001, 11:46 PM
As I said, I'd been taught to just insert the .swf file (that's created when you test the movie) into an html page in dreamweaver.... but that remains a fixed size - http://nickcurrie.com/htmlpages/flash.html

So now I've discovered that when you publish your settings, it actually creates an html page.... OK Mr Poab - I'm a derr brain!
Anyway, that worked fine, I uploaded it and all's OK, except for two other people that have tried it - and they can view the other one fine....?? here it is, can anyone view it? http://nickcurrie.com/htmlpages/Lmr.html
Thanks again...

"patience is a virtue"

Billy T
12-10-2001, 11:58 PM
is it meant to be a blank white page?

12-11-2001, 12:40 AM
No... surely this one works - http://nickcurrie.com/htmlpages/flash.html
It's the 100% one that's only working on mine - they're exactly the same file except for the dimensions....?

Billy T
12-11-2001, 01:36 AM
oh yeah working now...not scaling though

12-11-2001, 02:29 AM
Aaaaggghhh - I know what I've done wrong now, sorry it's too embarassing to say...
Thanks for your patience and all your help!

12-11-2001, 11:39 PM
before i give any further comments could u be a bitt more specific as to what exactly you are tryin to do. are you trying to make is so that depending on how much the user reduces his/her browser window, the swf scales along with that. if that is the case, i do believe that is the default setting in flash, as i am trying to do the complete opposit of what you are doing and regardles of what i do, the window and content therein always scales down. i wish i knew how to make it so that if the window got scalled the cotents remained intact. let me know

12-12-2001, 02:45 AM
RightyO, yes that's what I've been trying to do, make the site fit any sized browser window so there are no scroll bars.
I'm not sure what the default settings are in the publish settings, but when I changed them to 100% it made no difference when I uploaded the site. That was because I, as always, inserted the .swf into an html page that's created when you test the movie, which appears to be unaffected by the publish settings. Hence it remains at the set dimensions...
Hope that helps

12-12-2001, 09:59 AM

When you publish the Flash movie, don't embed it in an html page or anything. Copy and paste the code Flash generates (from object to object, don't include the other html elements). That way the code that relates to the Flash movie is exactly what you specified in the publish settings.

If you don't want it to resize (Taldos) set specific pixel dimensions when you publish it. I assume you did that and it doesn't work? It does for me, how are you doing it?


12-12-2001, 12:30 PM
r u importing the swf/html published page into another html page first, cause if u are that would explain why it is not resizing

12-12-2001, 09:44 PM
No, no - I just right click on the published file, which gives me the option to 'edit in dreamweaver', then I just save as. Thing is it's It's actually working now, even when I upload it and test it, it's fine - except when other people try, it wont load..??? How does my browser find it, and others can't?
http://nickcurrie.com/htmlpages/flash.html this one wont resize, but loads fine, yes?
http://nickcurrie.com/htmlpages/Lmr.html this one resizes, and I can view it perfectly, but can you?

12-14-2001, 10:25 AM

First one is as you say.

Can't see second one.

The first one isn't resizing because the code is telling it not to. Change the code (by hand) to 100%.

Also you shouldn't really use the Div element like that. Use a table with a single cell.


12-15-2001, 02:16 AM
go to someone elses computer...
browse to your second page...
you will see nothing so click view source (ie) and look at your parameters...
the parameter tells the browser where the swf file is located, is pointed at your harddrive... not at a file on a web server. put the correct path in that parameter and you should have it.