PDA

View Full Version : accessing a local document


caldive
01-29-2002, 04:27 PM
We have made 3 pages of buttons in flash to bring together 157 documents for a mail out cd, however flash will not link to word documents, so we are more than happy to save all these files as html. but the problem comes in when we try to link to them, we can't get flash to link to a local file. Caldive also has director 8.5, but, that presents a whole new set of problems. We tried to import the three pages created in flash into director just so we can access these files, but found no way to accomplish this. The CDs need to be mailed out next week, and we can find no solution to the minutely simple task of just linking to these files. If no one has any answers then we will just have to declare that flash and director are useless for creating presentations, and return to just using power point (a cheesy program, but it at least can access local files).

Can anyone offer any solutions?

Ricod
01-29-2002, 04:56 PM
Anyway, do u know getURL ?
getURL("myFile.ext");

And for the standalone (your case) :
filename = "test.pdf";
fscommand ("exec", "start\t" + filename);
fscommand ("exec", "cmd\t/c\t"+filename);


straight from the tutorial :
http://www.actionscripts.org/tutorials/beginner/exec_docs/index.shtml

caldive
01-29-2002, 05:08 PM
we have tried "get url" but it keeps trying to drop the http:\\ in front of the filename. but we will keep trying.

Ricod
01-29-2002, 05:14 PM
You're using a standalone, so u'll need to use the FSCommand. Sorry for that, I'm not fully awake at the moment. (See previous post, though)

caldive
01-29-2002, 06:40 PM
thank you for the help Ricod. We'll give it a try. If it works GREAT, we've got a new way to show presentations,
if not there's always (EVIL) powerpoint.

red penguin
01-31-2002, 01:11 PM
I'm just going to stick my neck in here to say that I really hope that there is a solution OTHER THAN that other program put out by the Big Log software company that doesn't give their users the choice of freedom...

so there...

tg
01-31-2002, 04:25 PM
check out this link, it may help.
http://www.actionscripts.org/forums/showthread.php3?threadid=7999&highlight=file%2F%2F

ricod, your method (fscommand) won't work for anyone who has downloaded the newest flash player, cause mm has disabled the "exec" command to curtail viruses...

red penguin
02-01-2002, 12:10 AM
Good point, tg...I hadn't even thought of that issue...Damn those menacing viruses!

tg
02-01-2002, 04:41 PM
it also makes me wonder if they have killed the undocumented fscommand("save",filename); option also...
can anyone who has downloaded and installed the new player test it to find out???