PDA

View Full Version : Flash 8 Video Encoder Not Working on OS X?


gluefreak
12-20-2005, 12:12 PM
Here's a weird one. I was having problems encoding some flv files using the Flash 8 Video Encoder. They work locally but not when I post them to a server. I thought it was a MIME type issue or something -- but it's not, and other .flv files (encoded by anyone but me) work on my server.

After much hair-pulling, I determined that any .flv I make on my default computer, a PowerBook running OS 10.4.3, won't work. (I've seen the tech note about Flash 8 Basic rendering the encoder inoperable, and that's not my situation. I've always had Pro.) I can take the same video files -- a variety of QT, WMV, and MPEG -- and encode them on the Win version of Flash 8 Video Encoder. They work just fine, locally and remotely.

Figuring that that there must be something weird about my PowerBook, I installed (from the same install disk) Flash 8 on another Mac running OS 10.4.3. This other Mac was reformatted recently and has very little software on it. It's never had Flash on it. And guess what? Any video I encode using Flash 8 Video Encoder on that machine also fails.

I hardly know what to make of the situation. I haven't seen any other users complaining about the Encoder not working on OS X, so it must be something about my Macintosh systems. But to have the Encoder fail on two different machines, one of which is practically virginal? It's very bizarre. If anyone has any suggestions what might be plaguing me, I'd greatly appreciate a response.

Thank you!

gluefreak
12-20-2005, 02:59 PM
Update on my situation.

I reformatted a G4 desktop with OS 10.4.3. (That was a clean install -- I reformatted the hard drive and installed 10.4, then updated via Software Update to 10.4.3.) I installed nothing but Flash 8 Professional on this machine. I encoded several test video files that I am able to encode successfully on Windows. I uploaded these to a server -- and they don't work.

It occurred to me that perhaps it's not Flash 8 Video Encoder. Perhaps the files are somehow being corrupted when I ftp them to the server. I took some of the flv files I encoded on Win and uploaded them from Mac (using Interarchy) to a server. They work just fine.

It's difficult for me to escape the conclusion that Flash 8 Video Encoder is failing to work on OS X, specifically on 10.4.3.

Is anybody using F8VE on 10.4.3? Is there any step in this process that I've failed to troubleshoot correctly? I don't know what to think about this situation. Is it possible that I have some sort of bad install disk? When I encode, everything seems to work. I just can't view Mac-encoded files when I post them to the server. Help!!!

benpotter
12-20-2005, 09:01 PM
gluefreak...are you referencing these .flv files in a .swf in flash 8? if so do you by chance have your parameters for a FLV Player Component set for streaming? ( i.e. is "live" set to "true" ) that function is for streaming media only... does that help? there are other parameters that could help... ben

gluefreak
12-20-2005, 09:44 PM
are you referencing these .flv files in a .swf in flash 8?

Yes.

if so do you by chance have your parameters for a FLV Player Component set for streaming? ( i.e. is "live" set to "true" )

No.

I've got several very basic apps that I've made for testing. One uses Flash's external api to test in an html page. Another is just an flv playback component on a stage.

The weird part is that the test apps work fine with any video I've encoded using the Windows version of F8VE. However, any video I encode on OS X fails to work. (And to repeat, one of the Macs I reformatted and installed a fresh copy of F8 Pro.)

Rather than beginning to play using progressive download, as the Win-encoded files do, the Mac-encoded files fail to start playing. They generate no error. (I've also used the live headers plugin in Firefox to determine that the correct MIME type is being used.) The browser gives the appearance that it's trying to cache the entire file before playing it, but then once the file is done loading it fails to play. I've tried this on Safari, Firefox, and IE -- on Win XP and OS X.

Win-encoded files work. Mac-encoded files don't. I've tested every other part of the process and I can't reach any other conclusion. My Macs are running OS 10.4.3 with QT 7.0.3 Pro. These are the latest versions of OS X and QT. I haven't tried reverting to older versions, though.

I'm aware of the Macromedia Tech Note that says F8VE fails if you've installed Flash 8 Basic:

http://www.macromedia.com/go/382c6367

But that's not the case on either of my Macs, especially the one I reformatted!

I'm also aware of the Macromedia Tech Note that says you can't make flvs on OS X when you have both QT 7 and Flash MX 2004:

http://www.macromedia.com/go/479daf71

I did have Flash MX 2004 on my one machine, but I figured the upgrade to Flash 8 would fix this issue. I did not have MX 2004 on my other machine, since I reformatted it and installed F8 alone. The Tech Note indicates that the F8VE should work under these conditions.

I'm really stumped. I'm an experienced developer well-versed in Macromedia products and various multimedia technologies. I've tested this every way I can think of -- well, almost. I haven't downgraded to older versions of OS X or QT. Otherwise I'm forced to the conclusion that the OS X version of the Flash 8 Video Encoder just doesn't work -- which is why I'm curious to know if it works for anybody else. It must, mustn't it?

gluefreak
12-24-2005, 08:56 PM
Update: It occurred to me that I hadn't tried to create an .flv by exporting via QT on Mac (rather than using the F8 Video Encoder). Using QT 7.0.3, I exported a QT file that I've been able to encode successfully on Windows. The resulting .flv file is 2MB larger than the Win-encoded .flv and fails to play when I upload it.

Could it be that there's something with the latest version of QT that hoses .flv encoding? I can't believe that nobody else is doing this on OS X...

gluefreak
12-24-2005, 09:29 PM
Another Update: The Flix encoder from on2 (on2.com) works on my OS X systems but the F8 video encoder doesn't. That would imply that QT isn't the problem but that there's something weird about the Macromedia encoder itself.

Rabi
04-17-2006, 10:15 PM
Hello,

I am having problems related to flash 8 video on MAC. Something that runs smooth on PC doesn't run on MAC. I used Safari to play the file and it kind of hangs.

Does anyone know of issues like flash video not playing on MAC.
Rabi

Daphne99
06-22-2006, 06:53 AM
Just came across your post and just wanted to let you know that I'm running OS X 10.4.6 and Flash 8 and my encoder has been working fine. Just wanted to put it out there that it is possible. I've been encoding QT's all this week with no problems after just having upgraded to 8. So it is possible but I'm sorry I have no clue...you seem to have tried everything I would have already!

CyanBlue
07-06-2006, 04:58 PM
I personally had bad experience with that program and I don't recommend it if you ask me... :(

RyanSF07
03-07-2007, 03:35 AM
Gluefreak,

I'm having this same problem (that you had). I found your post via a google search. I'm running the same OS X that you were -- tried today encoding on a different computer with newer OS, and the video still doesn't play! aarrgh

Did you ever figure out a solution?

Please let us know. Thanks,
Ryan

sylviod
03-14-2007, 07:20 PM
This problem has been there for a long time. The only way I found how to resolve it was to encode on Windows.