PDA

View Full Version : Preloader works in Firefox, not in IE!!


Vibrasphere
12-21-2005, 03:02 PM
Hi flashers ;)

I recently bumped into this problem, and I really don't know what or where it goes wrong :confused:

I made a preloader for my website, and it works in the download simulator, it works in Firefox, but not in Internet Explorer!! The preloader doesn't appear untill the whole movie is loaded in IE. In Firefox it works fine.

I don't know if it is an Actionscript-issue or a HTML-issue. But I hope somebody knows the solution to this problem...

You can visit the website here (http://www.vibrasphere.be/TheNewFriends) if you want to test it. The website is in Dutch, because I'm from Belgium :)

Actionscript of the preloader:
//PRELOADER frame 1
var Totaal = _root.getBytesTotal();
var Geladen = _root.getBytesLoaded();
var Verhouding = Geladen / Totaal;

preloader.loadText.text = Math.round(Verhouding * 100) + "%";
preloader.loadBar._width = 170 * Verhouding; //width of the preloader is 170px

//PRELOADER frame 2
if (Geladen == Totaal) {
preloader.loadPrefix.text = "Laden voltooid!";
preloader.loadText.text = "";
stop();
gaVerder = setInterval(function(){clearInterval(gaVerder); gotoAndPlay(3);}, 1000); //short break of one second before it continous to frame 3
} else {
gotoAndPlay(1);
}


My HTML:
<? xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>&nbsp;The New Friends &nbsp; </title>
</head>

<body>
<object type="application/x-shockwave-flash" data="website.swf" width="950" height="560">
<param name="movie" value="website.swf" />
</object>
</body>
</html>

Vibrasphere
12-21-2005, 05:44 PM
Ok, I fixed it :) I always write my HTML myself, and now I let Flash publish an HTML-file and I took the object-tag out of this file, and used it in mine. Now it works! :D