Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 09-05-2006, 07:06 PM   #1
VitiminD
Registered User
 
Join Date: Jan 2003
Location: Akron, OH
Posts: 43
Default Flash + Div + Transparency + Mac = Trouble

The URL in question is

http://www.prosprayfinishes.com/sub....oducts&catid=3

Works fine and dandy on a PC, but when you look at it on a mac..the hidden part is hidden fine but you can't click on anything that is supposedly under the hidden part.

Has anybody encountered this issue before? Any workaround before I scrap the whole flash thing and redo it in DHTML (gag).

P.S. You should see a turquoise background on a pc just for the visual sake of the dimensions of the swf.

Thanks!
VitiminD is offline   Reply With Quote
Old 09-05-2006, 07:08 PM   #2
VitiminD
Registered User
 
Join Date: Jan 2003
Location: Akron, OH
Posts: 43
Default

Forgot to add some pertinent information...

The swf is in a div with the following style applied to it.

#container {
width: 100%;
height: 10px;
background-color: #00FFFF;
float: left;
margin-right: -200px;
margin-top: -13px;
z-index: 2;
position: absolute;
}

Also, the swf is outputted via javascript to fix the IE issue.. but that isn't the issue since I have tried it the normal way as well with the same results. It seems wmode is being used correctly in both the embed and param tags.
VitiminD is offline   Reply With Quote
Old 09-06-2006, 12:08 AM   #3
supa
Registered User
 
Join Date: Aug 2006
Location: Germany
Posts: 10
Default

The wmode parameter is not supported by all and every version of Mac browsers. As far as I know the only parameter that works without any errors is "normal". "Opaque" and "Transparent" can cause errors in some Mac browsers.

I would'nt use this mode at all , many old window browsers have the the same problem.
supa is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
IE 5 MAC trouble - Flash Movie Disiapears when you scroll.. igeek ActionScript 1.0 (and below) 0 04-29-2005 08:59 PM
scrollBar on Flash Exchange cdeg Components 5 05-03-2004 07:13 PM
enterframe and load and objects, oh my! dice ActionScript 1.0 (and below) 13 07-18-2003 11:07 AM
Trouble Shutting Down Flash in Powerpoint Deadhands ActionScript 1.0 (and below) 2 02-09-2003 11:20 AM
Php, Javascript, and Flash 5 browser detect and more! Redline01 Server-Side Scripting 2 08-11-2001 01:09 AM


All times are GMT. The time now is 04:39 AM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.