Home Tutorials Forums Articles Blogs Movies Library Employment Press

Go Back   ActionScript.org Forums > Extensions and Plugins > Components

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-18-2007, 06:09 PM   #1
jsauna
Registered User
 
Join Date: Jun 2005
Posts: 11
Default help with flv video interface

Hi!
I'm trying to put together a number of videos on a single module. I'm don't know much actionscripting, so i thought the easiest way to go about it would be call the URL for the different movies on frames 1, 2, 3, 4 etc, then create buttons as icons for the movies which will in turn "go to and play" at frame 1, 2, 3, 4...

I've actually managed to get my interface to work, but I still have one major problem. If I click on another movie while one is still playing, they both play together. how can i get one movie to stop when the other starts playing? I'm assuming I have to put some actionscript in the buttons, but have no idea what.

You can view what i have so far at: http://www.publicintegrity.org/video...und_Video.html

Can somebody please help? I'm running on a deadline, and need to get this done fast

I am using Flash 8 Professional.

thanks
jsauna is offline   Reply With Quote
Old 04-18-2007, 06:39 PM   #2
nadafinga
Registered User
 
Join Date: Apr 2007
Location: Champaign, IL
Posts: 38
Default

it's hard to say without seeing your actual script/.fla, but for what you are doing, I would assume that you need to make sure the keyframe for each movie starts and ends at it's specified frame, so "movie01" that loads on "frame01" doesn't continue in the timeline at frame 2..... and the same for each frame that contains a movie....

hope this helps

oh, and use gotoAndStop... not gotoAndPlay
nadafinga is offline   Reply With Quote
Old 04-18-2007, 07:01 PM   #3
jsauna
Registered User
 
Join Date: Jun 2005
Posts: 11
Default

thanks for the response. I tried GotoAndStop, but that doesn't help either. I can attach my original fla file if you'd be willing to take a look at it.
jsauna is offline   Reply With Quote
Old 04-18-2007, 07:16 PM   #4
nadafinga
Registered User
 
Join Date: Apr 2007
Location: Champaign, IL
Posts: 38
Default

Quote:
Originally Posted by jsauna View Post
thanks for the response. I tried GotoAndStop, but that doesn't help either. I can attach my original fla file if you'd be willing to take a look at it.
that would be helpful to myself or anyone trying to help you.....
nadafinga is offline   Reply With Quote
Old 04-18-2007, 07:26 PM   #5
jsauna
Registered User
 
Join Date: Jun 2005
Posts: 11
Default

okay, here it is. Thanks again
Attached Files
File Type: zip Superfund.zip (133.5 KB, 89 views)
jsauna is offline   Reply With Quote
Old 04-18-2007, 07:58 PM   #6
nadafinga
Registered User
 
Join Date: Apr 2007
Location: Champaign, IL
Posts: 38
Default

here you go, just as I thought, the problem was what I addressed in the first post, you need to eliminate the movie from the timeline after it's initial keyframe (shift + F5). Good luck and enjoy.

p.s. it's a slow day so i fixed some text alignment issues for you, and tidied up your script a bit as well....
Attached Files
File Type: zip SuperFund_Video_fixed.zip (79.2 KB, 102 views)
nadafinga is offline   Reply With Quote
Old 04-18-2007, 08:06 PM   #7
jsauna
Registered User
 
Join Date: Jun 2005
Posts: 11
Default

thank you so much! that was great. It's so frustrating trying to teach myself, cuz i spend hours on a problem and then someone like you come along and fixes it in seconds.
now i gotta tackle buffer time. but hey! this is great. thanks again
jsauna is offline   Reply With Quote
Old 04-18-2007, 08:12 PM   #8
nadafinga
Registered User
 
Join Date: Apr 2007
Location: Champaign, IL
Posts: 38
Default

hey no problem (seems like you are working for a good cause), don't get too frustrated, in most circles I would be considered a flash newb as well. Just study what I did (after you meet your deadline of course!) then compare it to what you had, and you should be able to see what I did and why. Hint: the problem you were having wasn't in actionscript (even though I changed it a bit to make it a bit cleaner) it was in the way you had your timelines/layers set up......

Last edited by nadafinga; 04-18-2007 at 08:17 PM.
nadafinga is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I load a flv in flash: I hear audio but dont see video, why? loca Other Flash General Questions 1 03-24-2007 05:44 AM
Repeating a FLV video blakerblaker ActionScript 2.0 2 02-22-2007 05:08 AM
RGB Video Properties / Display Dulplicate Interface Output DreamLoader Projectors and CDs 0 07-11-2006 10:03 AM
Some Flash Video Converter Tools Compare terry117 Detention 7 05-18-2006 02:08 AM
Loading external video streams into Flash interface - options? ian27 Other Flash General Questions 0 09-26-2005 05:39 PM


All times are GMT. The time now is 09:58 AM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.