Home Tutorials Forums Articles Blogs Movies Library Employment Press

Go Back   ActionScript.org Forums > Extensions and Plugins > Components

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-11-2007, 06:27 PM   #1
eldritch
Registered User
 
Join Date: Jul 2006
Posts: 4
Default [AS2] disappearing SeekBarHandle in FLV Playback component

has anyone found a solution for the disappearing SeekBarHandle?

when using the FLV Playback component and setting the buffer time to any significant time (10 seconds in my case), the SeekBarhandle disappears once buffering is completed

i tried the following code to try to figure out what was going on ("controls" is the name for the clip that contains the buttons and seek bar, and "handle_mc" is what Flash names the SeekBarHandle)

this.onEnterFrame = function () {
trace(_level0.controls.handle_mc._x + "," + _level0.controls.handle_mc._y);
trace(_level0.controls.handle_mc._visible + "," + _level0.controls.handle_mc._alpha);
}

what i found is once buffering starts the handle_mc._visible is set to false by Flash and not switched back once buffering ends

the handle_mc does not move along the seek bar either

so i tried the following code forcing handle_mc to visible, hoping handle_mc would start moving along the seek bar...

var listenerObject:Object = new Object();
listenerObject.stateChange = function(eventObject:Object):Void {
if (eventObject.state == FLVPlayback.BUFFERING) {
trace(FLVPlayback.BUFFERING);
}
if (eventObject.state == FLVPlayback.PLAYING) {
trace(+FLVPlayback.PLAYING);
_level0.controls.handle_mc._visible = true;
}
};
base.myplayer.addEventListener("stateChange", listenerObject);

...unfortunately this didn't work

i also tried taking the buttons and bar out of the clip, and putting them and the player all on the root level

again this did not work...

does anyone have an idea on how to fix this?
eldritch is offline   Reply With Quote
Old 06-11-2007, 07:28 PM   #2
LOLFlash
Senior Member
 
Join Date: May 2007
Location: Toronto,Canada
Posts: 530
Default listeners

Hi eldritch

I never had problem like you, But I had unaspected behavors when attached code to component directly and use Listener the same time, as well as when use AS1 listeners along with AS2 listeners
LOLFlash is offline   Reply With Quote
Old 06-11-2007, 08:12 PM   #3
eldritch
Registered User
 
Join Date: Jul 2006
Posts: 4
Default

yeah unfortunately the problem occurs if a Listener is used or if it isn't...
eldritch is offline   Reply With Quote
Old 06-11-2007, 08:16 PM   #4
LOLFlash
Senior Member
 
Join Date: May 2007
Location: Toronto,Canada
Posts: 530
Default post code

the only way to help if you create sample code and post it
LOLFlash is offline   Reply With Quote
Old 06-11-2007, 10:05 PM   #5
eldritch
Registered User
 
Join Date: Jul 2006
Posts: 4
Default

thanks for the help but there is really no code to post...

you drag player on to stage, name it, drag out the seek and buffering bars to stage, name them (i.e. buffer_bar, seek_bar)

stick in this code

myplayer.bufferingBar = buffer_bar;
myplayer.seekBar = seek_bar;
myplayer.contentpath = "http://www.url.com"

set buffer time in the player parameters (10 seconds)

and that's it...

if the player has to buffer, the SeekBarHandle disappears

eldritch is offline   Reply With Quote
Old 07-02-2007, 10:00 AM   #6
Blaeze
Registered User
 
Join Date: Jul 2007
Posts: 4
Default

I get exactly the same problem. Not sure what to do either. Seems like I can go up to about 0.7 buffer time before the problem starts occuring. Don't have much time to look into it as pressing deadline but would be good to hear of any solution.
Blaeze is offline   Reply With Quote
Old 06-25-2010, 07:24 AM   #7
H-N8
Registered User
 
Join Date: Jun 2010
Posts: 1
Default

Anyone ever find a solution for this? I have the same issue, but it only occurs after I deploy it to the server, not from the localhost. I suppose this has to do with the buffering as well, but hard to know for sure.
H-N8 is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding Images to the List component while using the FLV PLayback coldfusion.developer Components 2 08-17-2007 09:57 AM
FLV Video Not playing with media playback component odysseyfilms Components 2 06-24-2007 06:21 PM
FLV playback component VS video symbol pitale ActionScript 2.0 1 05-15-2007 09:28 AM
XML playlist but won't play in FLV playback component davinepictures Components 1 11-14-2006 08:29 PM
Playback Component Problems ukdigitalguru Components 1 02-27-2006 04:42 PM


All times are GMT. The time now is 04:44 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.