Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 09-10-2007, 07:01 PM   #1
justyna
Registered User
 
Join Date: Sep 2007
Posts: 4
Default problem with flash banner

Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters inside embed flag, that it can't be used at all... how can I do to repair this? I know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help.
justyna is offline   Reply With Quote
Old 09-10-2007, 07:05 PM   #2
lukaszw
Registered User
 
Join Date: Sep 2007
Posts: 2
Default

Quote:
Originally Posted by justyna View Post
Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters inside embed flag, that it can't be used at all... how can I do to repair this? I know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help.
... you should look in page source and it will be all clear ...
lukaszw is offline   Reply With Quote
Old 09-10-2007, 07:07 PM   #3
justyna
Registered User
 
Join Date: Sep 2007
Posts: 4
Default

Quote:
Originally Posted by lukaszw View Post
... you should look in page source and it will be all clear ...
I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??
justyna is offline   Reply With Quote
Old 09-10-2007, 07:08 PM   #4
lukaszw
Registered User
 
Join Date: Sep 2007
Posts: 2
Default

Quote:
Originally Posted by justyna View Post
I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??
Ok, I see you're a noobie... look, this is a source code from www.salagedata.com:

<object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="69" height="70">
<param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />
<param name="quality" value="high" />
<img src="http://www.salvagedata.com/templates/sd2007s/images/salv.gif" width="69" height="69" alt=" "/>
</object>

you can see, that there is gif file in <img>, but you should look inside param's too, so

<param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />

as you can see here is swf file inserted and IE displaying that file, instead animated gif ...
lukaszw is offline   Reply With Quote
Old 09-10-2007, 07:10 PM   #5
justyna
Registered User
 
Join Date: Sep 2007
Posts: 4
Default

Quote:
Originally Posted by lukaszw View Post
Ok, I see you're a noobie... look, this is a source code from www.salagedata.com:

<object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="69" height="70">
<param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />
<param name="quality" value="high" />
<img src="http://www.salvagedata.com/templates/sd2007s/images/salv.gif" width="69" height="69" alt=" "/>
</object>

you can see, that there is gif file in <img>, but you should look inside param's too, so

<param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />

as you can see here is swf file inserted and IE displaying that file, instead animated gif ...
thanks for your help
justyna is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
flash focus problem on re-entry to html window DotsC ActionScript 1.0 (and below) 10 11-20-2009 05:09 PM
Some Flash Video Converter Tools Compare terry117 Detention 7 05-18-2006 02:08 AM
banner tracking of flash banner in flash website asifkilwani Server-Side Scripting 0 05-17-2005 07:24 AM
scrollBar on Flash Exchange cdeg Components 5 05-03-2004 07:13 PM


All times are GMT. The time now is 09:34 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.