Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 04-11-2008, 12:15 AM   #1
noobfosho
Registered User
 
Join Date: Apr 2008
Posts: 8
Default animating lyrics

i am trying to animate the lyrics to make it synchronize with the music.
on the test movie within flash itself, everything seems to work fine.

the problem happens when i upload my flash to a file hosting service.
when the flash starts playing, the lyrics are off track.

initially i thought that might be a problem that had to do with the streaming of the flash file but i have since added a preloader to the swf to make sure the entire flash is downloaded before it's being played, and the problem still continue to persist. anyone can identify what wrong with it ? much appreciated.

preloader - h1.ripway.com/paperheader/pl.swf

actual flash - h1.ripway.com/paperheader/taiji.swf

Last edited by noobfosho; 04-11-2008 at 12:18 AM.
noobfosho is offline   Reply With Quote
Old 04-11-2008, 03:33 AM   #2
ASWC
Super Moderator
 
ASWC's Avatar
 
Join Date: Dec 2007
Location: Greenville, SC
Posts: 6,528
Default

are you loading the sound dynamicaly?
__________________
aswebcreations
Super Duper!
ASWC is offline   Reply With Quote
Old 04-11-2008, 04:07 AM   #3
atomic
Banned by AS.org Staff
 
Join Date: Jan 2007
Location: Montréal, Québec
Posts: 14,073
Default

Sound's Sync must be set to stream, not to event.

On the sound layer (which should only have the sound), you must also add as many frames needed to see the whole of the sound's modulations, till the blue line comes to an end...
atomic is offline   Reply With Quote
Old 04-11-2008, 10:04 AM   #4
noobfosho
Registered User
 
Join Date: Apr 2008
Posts: 8
Default

i've tested the sync using "streaming" and "start" mode.
both runs perfectly on the test movie within the flash sitmulate download mode.

the problem only happens when i upload it to the hosting site.
i've been working on it for a long time and cant find a solution to it, so fustrating !
perhaps i should finish the whole project before i start to sync the lyrics with the movie timeline.


my main file is at:

h1.ripway.com/paperheader/taiji.fla

if you guys like to see if its is a bug.
noobfosho is offline   Reply With Quote
Old 04-11-2008, 01:37 PM   #5
atomic
Banned by AS.org Staff
 
Join Date: Jan 2007
Location: Montréal, Québec
Posts: 14,073
Default

Did you read my post above?

Told you the only way to maintain sync online is to have the sound's Sync set to "stream", and to add those frameson the sound only layer...
atomic is offline   Reply With Quote
Old 04-11-2008, 04:08 PM   #6
noobfosho
Registered User
 
Join Date: Apr 2008
Posts: 8
Default

yeah i did.

i tested with stream mode. its not working either
noobfosho is offline   Reply With Quote
Old 04-11-2008, 05:20 PM   #7
atomic
Banned by AS.org Staff
 
Join Date: Jan 2007
Location: Montréal, Québec
Posts: 14,073
Default

Isn't this synced?

http://francoisgill.110mb.com/noobfosho/taiji2.swf
atomic is offline   Reply With Quote
Old 04-11-2008, 11:58 PM   #8
noobfosho
Registered User
 
Join Date: Apr 2008
Posts: 8
Default

hey that taiji.swf on your hosting sync'ed well.

was there any changes ? did you publish with the *.fla i used ? i was getting different results when i upload to my hosting site...
noobfosho is offline   Reply With Quote
Old 04-12-2008, 12:02 AM   #9
noobfosho
Registered User
 
Join Date: Apr 2008
Posts: 8
Default

heck, iwas my mistake. i think it was a site cache problem...the swf must have worked after i changed it to "stream" mode.

thanks for your help !
noobfosho is offline   Reply With Quote
Old 04-12-2008, 12:19 AM   #10
atomic
Banned by AS.org Staff
 
Join Date: Jan 2007
Location: Montréal, Québec
Posts: 14,073
Default

Grrrrrreat!
atomic is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulling Lyrics from a MP3 dynamically? tony@verve ActionScript 2.0 2 06-17-2008 04:52 AM
Bitmap filters over animating movieclip? bluerattle ActionScript 2.0 0 11-14-2007 04:20 PM
child MCs stop animating, but timeline is moving mex ActionScript 2.0 2 03-10-2006 02:44 AM
Lyrics for media player. SkyNarc ActionScript 2.0 3 07-30-2005 09:26 AM
Questions for toturial: Animating Text By Using ActionScript myecomdk ActionScript 1.0 (and below) 13 02-20-2004 06:02 AM


All times are GMT. The time now is 06:36 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.