Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 10-22-2009, 11:58 PM   #1
clesueur
Member
 
Join Date: Oct 2007
Posts: 59
Default NetStatusEvent error when Main class defined

Hi, has anyone come across/know what the problem is with this...

Ive got a flash file linking to a FMS, its just going to be a little game, all connects fine and I have a chat client working through this. My problem is when i come to use classes to import movieclips ect...

When i set the main Class name in the properties menu and play the swf,
NetStatusEvent and SyncEvent are give me the following error...

1046: Type was not found or was not a compile-time constant

If i remove the main Class name the swf connects to the server fine, or if i remove the code for the connection to the server and play the swf my movieclip attaches and behaves as the class files intended.

Has anyone had a problem like this before?

Im new to AS3 and to FMS so i may be doing a fundamental error here but i really cant see it and its annoying with the 2 aspects running independently but not together.

Help please

Chris
clesueur is offline   Reply With Quote
Old 10-23-2009, 11:05 AM   #2
clesueur
Member
 
Join Date: Oct 2007
Posts: 59
Default anyone?

anyone?
clesueur is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:52 AM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.