Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 08-12-2011, 03:58 AM   #1
AndreOM
Registered User
 
Join Date: Aug 2011
Posts: 3
Default [AS3] Flash rendering slows on Win 7 <= 2GB RAM

Our running platformer game has some issues with Flash rendering, I guess.
It is a run and jump game with fully animated character and 4 layers of parallax background.

The background consists of 4 layers:
1) one 700 x 400 JPG Background (most bottom layer, not moving)
2) two (at least) 700 x 400 PNG for second depth (parallax background, that's why there's we use two bitmaps)
3) another two (at least) 700 x 400 PNG for third depth (also a parallax background)
4) another two (at least) 700 x 400 PNG for fourth depth (also a parallax background)

Each bitmap is told to move, so we have a total of 6 bitmaps moving at the same time on each EnterFrame.

I used SWFProfiler to check out the stats and they're very good. Running the game at 30 FPS will get a stable 29.xx - 30.xx FPS gameplay, but there seems to be a lag when rendering.

This does not happen on 2GB Win XP machine or Win 7 machines with memory >= 3 GB.
However running the game on Win 7 machines with memory <= 2 GB would result a laggy background update (clogged / jitter).

The minimum requirement to run Win 7 properly by itself is 2GB so I'm guessing this issue is due to lack of memory.
We have created like 10 games now but no case like this happens before. Well, mainly that's because we have not created anything like this before. What do you guys think? Is there a solution to this except adding more RAM?
AndreOM is offline   Reply With Quote
Old 08-12-2011, 10:30 AM   #2
henke37
Senior Member
 
henke37's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 10,888
Send a message via Skype™ to henke37
Default

Don't guess, get real numbers. Find the real bottleneck and address it.
__________________
Signature: I wrote a pair of articles about the timeline.
henke37 is offline   Reply With Quote
Old 08-12-2011, 04:18 PM   #3
AndreOM
Registered User
 
Join Date: Aug 2011
Posts: 3
Default

Quote:
Originally Posted by henke37 View Post
Don't guess, get real numbers. Find the real bottleneck and address it.
That's exactly the problem. My memory usage is stable, there's no memory leak. This jittering happens even at earlier stage 1.

Could you please advise a way to find the problem? My conclusion so far is that flash requires more RAM.
AndreOM is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:28 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.