Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 03-25-2005, 03:50 PM   #211
SirNapalm
SirNapalm
 
SirNapalm's Avatar
 
Join Date: Mar 2005
Location: Switzerland
Posts: 89
Thumbs up Thank you!

Hi all!

I am new to these Forums and have signed up thanks to you guys talking down on preloaders! I had my trouble implementing these tricky things and you could help me - Thank you!

I work with Flash MX and am learning. Scripting was never my thing but I think you guys have unleashed the fury scripter in me!!

Hope I will be able to return my help sometime....

Until then all the best!

check out the alpha version of my site (no sound yet)
www.milkyhighway.ch/tps
SirNapalm is offline   Reply With Quote
Old 03-25-2005, 09:25 PM   #212
SirNapalm
SirNapalm
 
SirNapalm's Avatar
 
Join Date: Mar 2005
Location: Switzerland
Posts: 89
Question too much optimism...

It seems as though I have been too optimistic about my results and offline testing using Flash MX

I had trouble getting the preloader working at all. Then I had trouble getting it to show before it reaches 90%. I have all my mc's exported to the first frame through linkage and they do not "exist" on the main timeline. I have gone about this problem by creating a ghost (skipped, never played) scene which exists of frames including those mc and I took the export to first frame option off.

I tested the preloader and it worked beautifully. Smooth and from 0 to 100%. But when I upload my site it starts loading and stops at 4%. Nothing happens after that. How can this be that the test works in flash and not online? Does the problem lay on the side of the provider or browser? I am really lost on this one and would appreciate any help. If any code is required pls let me know.

progress here www.milkyhighway.ch/tps
SirNapalm is offline   Reply With Quote
Old 03-26-2005, 01:24 PM   #213
Tink
Addict
 
Tink's Avatar
 
Join Date: Nov 2001
Location: London
Posts: 2,128
Default

i wrote an AS 2.0, Flash 7 smooth loader class which can be found here http://www.flashgroup.net/forum/showthread.php?t=3121
Tink is offline   Reply With Quote
Old 03-26-2005, 01:45 PM   #214
SirNapalm
SirNapalm
 
SirNapalm's Avatar
 
Join Date: Mar 2005
Location: Switzerland
Posts: 89
Default too complex

First of all thanks Tink for an answer. Unfortunately the other code of the movie only works on Flash Player 6.

Can you tell me a reason why the testing in Flash works and online it doesn't work??

I am so lost with this.
SirNapalm is offline   Reply With Quote
Old 03-27-2005, 06:11 AM   #215
farafiro
Addicted To FLASH
 
farafiro's Avatar
 
Join Date: Dec 2001
Location: Egyptian in UAE
Posts: 12,436
Send a message via MSN to farafiro Send a message via Yahoo to farafiro
Default

hi
SirNapalm I think you need to look more about the basic preloaders first
all the provided work may look complex but too easy to be understand if you have a reasonable background and wanna learn
good luck
__________________
‚€* GOD Is Near ‚€*
Questions Don't PM for Questions . Thanks
An eye for an eye, make the whole world blind
_____________________________________________GHANDI
farafiro is offline   Reply With Quote
Old 03-27-2005, 10:43 AM   #216
SirNapalm
SirNapalm
 
SirNapalm's Avatar
 
Join Date: Mar 2005
Location: Switzerland
Posts: 89
Default

hi farafiro

You make sense. See I am a new to flash and only starting to learn. There is only that constant drive wanting to do the best I can. I am rethinking my project and will maybe start with something I understand and will write all the source code myself so I know what it does and how it works.

I will keep you guys posted on my progress...

Until then
SirNapalm is offline   Reply With Quote
Old 03-27-2005, 01:09 PM   #217
farafiro
Addicted To FLASH
 
farafiro's Avatar
 
Join Date: Dec 2001
Location: Egyptian in UAE
Posts: 12,436
Send a message via MSN to farafiro Send a message via Yahoo to farafiro
Default

good luck
__________________
‚€* GOD Is Near ‚€*
Questions Don't PM for Questions . Thanks
An eye for an eye, make the whole world blind
_____________________________________________GHANDI
farafiro is offline   Reply With Quote
Old 08-05-2005, 02:33 AM   #218
eyeronik
Senior Member
 
Join Date: May 2005
Posts: 156
Default

Finally I have found a preloaded with a masked image! That actually works! by wiggles! (the one after his which someone altered DOESNT work for me anyway)


!!!!!!!!!! MASKED IMAGE VERSION !!!!!!!!

I have updated wiggles to include the percentage amount like he said he meant to (just added the box and name of it)
Attached Files
File Type: zip wiggletest_B.zip (5.1 KB, 568 views)

Last edited by eyeronik; 08-05-2005 at 02:56 AM.
eyeronik is offline   Reply With Quote
Old 08-28-2005, 03:40 AM   #219
Bazzio
Registered User
 
Join Date: Aug 2005
Posts: 2
Default

Warrior posted this:
onClipEvent (enterFrame) {
Total = Math.round(_root.getBytesTotal()/1000);
Loaded = Math.round(_root.getBytesLoaded()/1000);
Percent = (Total)/(Loaded) *100;
if (Picture._currentframe<Percent) {
Picture.play();
} else {
Picture.stop();
if (Percent == 100) {
_root.play();
}
}
}

I cant seem to get it to work.
I have created a movie clip, and made a mask revealing a picture. It works, but just loops the reveal part and doesnt stop and start so that it completes on frame 100.
Thanks
Bazzio is offline   Reply With Quote
Old 08-31-2005, 05:54 AM   #220
Jackred22
Registered User
 
Join Date: Jun 2004
Posts: 93
Default preloading an swf learning quiz template to work.....?

Hello everyone!

First, this is a really kickass thread! The only problem is that I cannot preload a quiz template as an external swf, because everytime I try the movies navigation is disrupted and it will only show the welcome page...

Can someone try a preloader with a learning quiz template? I just can't get it!!

Thanks ever so much!!!!
Jackred22 is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:25 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.