Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 07-21-2004, 03:07 AM   #1
nycbrian
Registered User
 
Join Date: Jul 2004
Posts: 4
Default My Rollovers aren't working

Hi all,

The lowdown is that I am creating a site for someone and I made changes to one of the pages and now the rollovers aren't working. Its strange because I used the same code for the rollovers on for the main navigation and they work fine. I am going to post the page that is giving me problems, please keep in mind that this page loaded inside the main swf and is also loading a child swf within itself. On the buttons, I use the _parent reference instead of the _root reference to make sure it is refering back to the correct swf.

The rollovers aren't work and when you hover over the text it looks likes it blinking rapidly. Perhaps something is getting stuck.

Thanks for any help you can give.
Brian
Attached Files
File Type: zip work.zip (32.4 KB, 189 views)
nycbrian is offline  
Old 07-21-2004, 05:58 PM   #2
LordBurton
Registered User
 
Join Date: Jun 2004
Posts: 13
Default

Two things I would have done differently (Being new to flash I might be doing this wrong) But First off I believe to issue the command you wanted the text boxes had to be dynamic. And then give them a instant name to refer to. Next Instead of using just text as a button place a white box behind the text inorder to give it a better click.

I hope what I have attached helps you out.
Attached Files
File Type: zip alt-work.zip (33.6 KB, 163 views)
LordBurton is offline  
Old 07-21-2004, 10:20 PM   #3
myarro
Registered User
 
myarro's Avatar
 
Join Date: Sep 2003
Posts: 66
Default

The flickering is caused by the fact that the "hit area" for you button is the width of the letter strokes themselves, which you can easily move over and off in just a few pixels. You can solve this by adding a color block beneath the text, as part of the movieclip, and make that block a moveclip as well. Then set its alpha to 0, making invisible. Then you will have a nice, big hit area.
myarro is offline  
Old 07-22-2004, 05:51 AM   #4
nycbrian
Registered User
 
Join Date: Jul 2004
Posts: 4
Default

thanks for the help. That did it.
nycbrian is offline  
Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:59 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.