Home Tutorials Forums Articles Blogs Movies Library Employment Press

Go Back   ActionScript.org Forums > Flash General Questions > Flash 8 General Questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-20-2005, 04:31 PM   #1
thebob
Registered User
 
Join Date: Aug 2005
Posts: 124
Default using loadMovie to add a swf cancels the text anti-aliasing in the loaded movie?

I have a .swf with anti-aliasing on the text that works when it is opened in flash player 8 by itself.

I am using the following code:
ActionScript Code:
loadMovie("site.swf",loader);
to load a movie into a movieclip on the stage with the instance name of loader, but when site.swf is loaded in the anti-aliasing on the text doesnt work anymore.

Any ideas?
thebob is offline   Reply With Quote
Old 12-30-2005, 09:31 PM   #2
weetbixkid
Registered User
 
Join Date: Dec 2005
Posts: 1
Default Me too!

Quote:
Originally Posted by thebob
I have a .swf with anti-aliasing on the text that works when it is opened in flash player 8 by itself.

I am using the following code:
ActionScript Code:
loadMovie("site.swf",loader);
to load a movie into a movieclip on the stage with the instance name of loader, but when site.swf is loaded in the anti-aliasing on the text doesnt work anymore.

Any ideas?
I'm working on the same issue. Haven't solved it yet. Also, I'm finding that dynamic text generated with createTextField is rendered smaller in flash 8 than in flash 7.
weetbixkid is offline   Reply With Quote
Old 01-06-2006, 07:36 PM   #3
thebob
Registered User
 
Join Date: Aug 2005
Posts: 124
Default

Good to know someone has the same problem had any breakthroughs?
thebob is offline   Reply With Quote
Old 04-19-2007, 03:23 PM   #4
lucas.cerro
Registered User
 
Join Date: Apr 2007
Posts: 9
Default

I have the same problem.

I made a movieclip with bitmap text, set it to text without anti-aliasing and made sure that the text and every parent movieclip is on whole pixels (i.e. _x can't be 10.5 - instead I set it to whole numbers such as 10 or 11).

When I preview this SWF alone and on an HTML, the text displays correctly. But when I load this SWF from another file, the text comes in with antialiasing.

Anyone know of a solution? PS: It has to be Flash-7-compatible.

Thanks

*edit: I found this thread via search, and only now did I see that it was posted on the flash 8 forums. Sorry for the mistype.

Last edited by CyanBlue; 12-05-2010 at 08:24 AM.
lucas.cerro is offline   Reply With Quote
Old 04-19-2007, 04:04 PM   #5
atomic
Banned by AS.org Staff
 
Join Date: Jan 2007
Location: Montréal, Québec
Posts: 14,073
Default

Can you attach both .flas?
atomic is offline   Reply With Quote
Old 04-19-2007, 09:13 PM   #6
turtelly
Registered User
 
Join Date: Dec 2005
Location: WI
Posts: 26
Default

Double-check to make sure your loaded movies and the movie you are loading them into are all published to the same version of the Flash Player. I have encountered quirky somewhat inconsistent things with loaded movies if I accidentally have one published to a different version.
turtelly is offline   Reply With Quote
Old 04-20-2007, 06:55 PM   #7
lucas.cerro
Registered User
 
Join Date: Apr 2007
Posts: 9
Default

@Atomic: thanks so much for the willingness to help, but I've signed a NDA for this project, and can't make any file avaiable for now. I'll try to reproduce the problem at home this weekend if I get some free time.

@turtelly: Nice to know that. I checked the versions and they're all flash 7, though =/

To anyone that is interested, the solution I used was a mix of what ppl said here on the forum. Apparently, both rendering text as HTML (Dynamic Text Fields) and setting it to use "Device Fonts" force the text to be aliased.

In my case, since the text fields didn't have any style variations (size variation, bold, italic, etc) I converted it all to dynamic, multi-line text fields, using Device Fonts.

Thanks for the help, guys.

Lucas
lucas.cerro is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
loading images into dynamic text boxes mprovojr ActionScript 2.0 5 10-09-2007 06:10 PM
email form help nikmark Simple Stuff (Newbies) 17 06-14-2006 12:01 AM
external movie, text, css problem openeyes ActionScript 2.0 3 01-21-2006 07:07 AM
XML/ActionScript help pleeeeeeese....... witchking ActionScript 2.0 3 01-21-2005 06:42 AM
Turn OFF Anti aliasing in input text field? ebz ActionScript 1.0 (and below) 6 09-17-2002 07:42 AM


All times are GMT. The time now is 06:19 AM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.