Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 12-30-2005, 09:02 PM   #1
dmack
dmack = new Person()
 
Join Date: Jan 2005
Posts: 124
Exclamation component functionality lost

I'm finding that when an external swf that uses v2 Components is loaded into a movie clip on another swf, the component loses it's functionality (unless the hosting swf already contains the component, which in my case defeats the purpose.)

I'm trying to load a swf that has a comboBox into an mc on a different swf, but after it loads the comboBox no longer works; it has focus, but doesn't drop down.

Thank you.
__________________
I am an instance of the Person class.
dmack is offline   Reply With Quote
Old 01-30-2006, 05:53 AM   #2
mgomez03
Registered User
 
Join Date: Jul 2004
Posts: 91
Default

Quote:
Originally Posted by dmack
I'm finding that when an external swf that uses v2 Components is loaded into a movie clip on another swf, the component loses it's functionality (unless the hosting swf already contains the component, which in my case defeats the purpose.)

I'm trying to load a swf that has a comboBox into an mc on a different swf, but after it loads the comboBox no longer works; it has focus, but doesn't drop down.

Thank you.


I have the SAME EXACT problem!!! I have a main .swf file that loads (via loadClip) an external .swf that contains a v2 ComboBox. If the external .swf is tested alone the ComboBox works just fine... the trouble starts when my main .swf loads that external .swf into an empty container clip and then the ComboBox just won't work. I had the same problem with the TextArea component but I was able to solve that by adding two specific lines of code:

Code:
myTextArea.drawFocus = null;
myTextArea.focusTextField = null;

I google'd around and some say that it's a bug, but I've never seen confirmation from anyone about it.
mgomez03 is offline   Reply With Quote
Old 01-30-2006, 06:05 AM   #3
mgomez03
Registered User
 
Join Date: Jul 2004
Posts: 91
Default

gah, nm. http://www.actionscript.org/forums/s...mbobox+problem
mgomez03 is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Component Icon & Comp. Functionality bubba Components 4 01-22-2006 01:30 AM
Disappearing Component Functionality fuzzylogik ActionScript 2.0 1 12-29-2005 06:04 AM
VERY odd functionality..._global variable values being lost between function calls... mrand01 ActionScript 2.0 6 12-13-2004 07:00 PM
dynamic component (radiobutton) with setChangeHandler problem tROCK Components 6 08-25-2004 04:49 PM
help needed referencing a component instance inside my own custom component bleepbloop Components 4 08-06-2004 10:31 PM


All times are GMT. The time now is 04:50 AM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.