Home Tutorials Forums Articles Blogs Movies Library Employment Press
Old 01-04-2006, 11:19 AM   #1
impsvi
Registered User
 
Join Date: Sep 2005
Posts: 15
Default applying a mask to layers which follow a motion guide, not working

ooh arrrr, for some reason when i try to apply a mask to a guide layer and the layers below it (gfx which follow the guide), the layers dont get linked, the mask therefore doesnt work.

I tried placeing the mask layer inbetween the guide layer and the guided gfx layers blelow but it would not let me.

Can you do this in flash? were am i going wrong, my animation is quite simple: small molecule like circles follow a guide layer which is a line.
At a certain point in the line i want the molecules to be visable then further along the line it want them to dissapear. I thought a mask would best achieve this but it doesnt work.

Im using flash8 but publishing in mx2004, i would upload the .fla buts its to big and im not really suspose to make the content public not thats its secret or anything but beacuase its for a museum, i have included a pic tho.

thanks
Attached Thumbnails
Click image for larger version

Name:	maskingprob.jpg
Views:	430
Size:	90.4 KB
ID:	15850  
impsvi is offline   Reply With Quote
Old 01-24-2006, 05:28 AM   #2
raskolnikov
Senior Member
 
raskolnikov's Avatar
 
Join Date: Aug 2001
Location: kl, malaysia
Posts: 359
Send a message via MSN to raskolnikov Send a message via Yahoo to raskolnikov
Default

do it with actionscript instead of guided mask.
make your animation of your mask in one mov clip
name it say "mask1"

on your root make 3 layers.
one for the mask mov you just made "mask1"
one for the masked image, make this a mov clip too, name it "image"
one for actionscript put image.setMask(mask1);
__________________
"There is no solution because there is no problem" Marcel Duchamp
raskolnikov is offline   Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Mask rberry88 ActionScript 1.0 (and below) 2 09-14-2004 05:07 PM
Mask Not Working jalingo ActionScript 1.0 (and below) 3 03-23-2004 02:13 PM
my mask not working on a movieclip jbsykes Simple Stuff (Newbies) 1 03-03-2004 04:28 PM
Motion Guide Tween and color with AS mvhall ActionScript 1.0 (and below) 8 07-15-2003 07:49 PM
need help with transparency gradient in mask layers carlhusic Simple Stuff (Newbies) 3 01-02-2003 03:41 PM


All times are GMT. The time now is 06:55 PM.

///
Follow actionscriptorg on Twitter

 


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger
Copyright 2000-2013 ActionScript.org. All Rights Reserved.
Your use of this site is subject to our Privacy Policy and Terms of Use.